Shutdown item on latte dock

Hi all,

I am using only a latte dock and no panels. I´d like to have a button / widget to shut down immediately (properly, following the regular shut down procedure). Or configure the laptop power button likewise. Any suggestions?


PS: Still a noob; I recently left windows and I am missing my shutdown.exe taskbar button. Any click counts…

Hi @jagercode,

According to this page:

Open the Power/Session menu right at the bottom of the menu (as shown in the original question) and you will find your missing buttons.

Right-click on any one of them and add to favorites to show them in the favorites part of the menu.

Hope it helps!

1 Like

Just as an FYI… :arrow_down:

Almost; I have those in my application menu, but I do not want to open it but hit the power down button directly:


Yeah, so I’ve heard. Are my hopes too high the KDE team is going to absorb it and add it as standard Plasma component? That would comfort a lot of users, I guess.

Latte Dock 0.10 also suffers from some defects on 5.25. Version 0.11 seems to be on it’s way but there’s no ETA yet. AUR provides a latte-dock-git version which is allegedly free from these defects but I’d rather stay on the official repos.

There’s a plasma widget called lock/logout. Use it, configure it.

Only time will tell.

And you can’'t drag-and-drop 'em?

just install the git version. It does solve the multiple windows opening issue.

@sweasyf Overlooking the obvious!

After switching off the “30 seconds reconsider your choice” screen this works.

Now have to figure out if I can persuade my power button to behave likewise.
[ UPDATE: Found what I was looking for under power management settings. ]


Pretty much everything is configurable, remembering where and how to configure things and how those configurations affect other configurations is the hard part. It becomes rather maddening sometimes when they tweak default settings and you have to go remember how you made your system your system.
Recently they “took away” my logout method, right click desktop, bottom entry was “leave”. The devs decided no-one used that and removed it from the default right-click menu. It took me awhile to figure out how to get it back.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.