Shutdown causes reboot

Hello all,

I’m hoping for some friendly assistance. I just bought a brand new Alienware R10 Ryzen Edition. I am running windows 10 on the stock Nvme drive and I added a 1TB Sandisk SSD to run Manjaro GNOME off of. Everything seems to work perfectly fine except for the ability to shutdown from Manjaro. When I try to shutdown the computer it simply goes to a screen where I see the text “Power down” then it goes to my Alienware splash screen and back to the Manjaro GRUB screen.

I have tried using the “systemctl shutdown” command as well as the “shutdown now” command in terminal both commands render the same result. I also disabled every setting in my bios related to USB wake, Network Wake, or anything else that I thought could cause this issue. I checked for a BIOS firmware update and I am on the latest version. I also disabled Windows 10 Fast Boot.

I’m running Manjaro Pahvo 21.1.4, kernal 5.13.19-2

In order to actually shutdown the PC I have to reboot into Windows 10 and then shutdown. Not the end of the world but it is annoying. Any help resolving this is appreciated. I did search the Internet for a few days and could not find a viable resolution. I appreciate anyone willing to help me resolve this!

Thank You

Disabled hibernation too on Windows 10?

Tried the latest stable 5.14 kernel and/or the 5.10 LTS kernel?

1 Like

I will also disable hibernation in windows 10 and see if that helps. I am unfamiliar with how to switch the kernel in Manjaro but will try to look that up and report back if it works.

This might be an ignorant question but if I switch to an older kernel am I going to lose anything (features, performance, hardware compatibility)?


Switching kernel is really simple, Manjaro made tools specifically for that, either graphical or terminal application. From the GUI tool, simply click install on the desired kernel, and you’re good to go, reboot, select it, and see.

If you go to older kernel, indeed, features could not be present in some kernels and some hardware support could not exist, especially for your Nvidia card it requires a recent kernel, but I think 5.10 would work. You can always select the kernel you boot on so if you don’t remove your working kernel you can select it in the GRUB menu (which might be hidden by default when you boot, in that case you can spam the shift or escape key, I’m not sure which one currently, during the boot to show it, or you can reconfigure GRUB to force show the menu always).

I got switched over to the 5.14 kernel. I still have the same problem. I can try the older kernel, but I was really hoping to not go backwards because at some point I’ll have to update and I don’t want the problem to re-emerge.

This seems so bizarre to me as I was previously using linux on a 2009 Mac Pro 5,1 that Apple stopped supporting some time ago. I switched to linux because I was sick of hacking the computer to get the updates/newer OS installed. Linux ran perfect too, but unfortunately the way Apples BIOS works if there was ever a problem I would have solid black screens and no way to recover which led to formatting and re-installing which got old quick. So I caved and bought a PC. I thought for sure I’d be better off.

5.10 is a LTS kernel, and will have support for many years The Linux Kernel Archives - Releases.

Did you disable hibernation in Windows?

This is not a common issue besides one other guy who never replied to what I suggested to him, I didn’t see other people having the issue.

Windows fastboot and hibernation is known to create issues, for example I already saw unusable hardware, I think it was the network LAN or WIFI chip that was locked in a weird state and was not working under Linux but working under Windows, as soon as the user disabled these features it worked as intended under Linux. So worth a try.

//EDIT: also, non LTS kernel have a short lifespan so as you’re using non LTS kernel, remember to check when they are declared EOL as they will get removed from Manjaro after a small grace period.

No, I haven’t tried disabling windows 10 hibernation yet. I will do that and try the LTS kernel. I never use Windows unless there’s a specific need that can’t be resolved in any other OS. I appreciate your help.

I still have other ideas to look at if it doesn’t work so let see for now if this fixes it, and if not I’ll drop more stuff to try :wink:

Disabled Windows 10 Hibernation - Didn’t resolve issue
Switched to 5.10 LTS Kernel - also didnt resolve issue.

Would any of these BIOS settings cause this? - I had attached a picture and then it told me I cant attach media items and apparently I cant include links which seems so counterproductive!
Essentially there are TPM settings, Something called PPI Bypass for Clear Command, and Windows SMM Security Mitigation Table.

OK no luck.

New users on the forum have limited permission, it will change if you’re active on the forum. In the meantime, share links with a trick, by having them as code, by having backticks around it like that `````` (or select it and click the code button </>

Try a boot on Windows 10, then reboot from Windows 10 to Manjaro, and try a shutdown. In that scenario does it shutdown properly from Manjaro?

Try reboot with shutdown -P now and see if it shutdowns properly.

Try a reboot without network cable (I know you disabled WakeOnLAN but for the sake of testing, do it).

Here’s the original picture of some of the BIOS Settings I didnt know what to do with so I left them as default. I will try your recommendations now.

Okay, all 3 of the above suggestions did not fix the issue. I am getting a message when trying to shutdown regardless of method the screen very briefly flashes a message in the upper left hand corner of the screen that states: 53.467790 reboot: Power down - but then the machine just reboots.

Unfortunately I’m not familiar with those BIOS settings, you’ll have to try and/or resort to Google to find what they do.

Something I’m thinking about, is to pass ACPI kernel parameters, maybe that could help/fix the issue.

Maybe other kernel parameter could fix the issue, I actually don’t know. I’m out of idea for now. I would double check the BIOS settings, maybe open a support ticket to your board manufacturer, they may know something that could help.

There is a setting in my BIOS for my power switch. I changed the value to shutdown. Now when in Linux if I press the power switch it shuts down the machine and it actually works. The issue I currently see is when you shutdown from terminal or via the GUI button in Manjaro I believe it goes through a process where it stops various running processes before actually turning the computer off. When I press the power button I dont see any of this the screen goes black and back to the splash screen of the computer and then it shuts off. Is this going to cause any issues with the Operating system by shutting down this way? I feel like it is kind of like just unplugging a powered on machine.

On a side note I do not know anything about ACPI kernel parameters or how to add them, but the article you posted looks promising so I will check this out and report back if you wish. If not then I appreciate your help thus far and we can close the thread.

Update: I implemented the ACPI from the thread… It didn’t fix the problem, but did make my computer take twice as long to boot. LOL. Im at a loss.

Don’t power down the machine (if it goes from On to Off instantly this is not a shutdown, it is a direct power off), I’m not sure what parameter you’re talking about.

Which parameter did you add? The thread list many, especially the acpi_osi ones. There is probably one good for your computer.

Give full inxi info too How to provide good information

I followed the guide and edited my grub file via terminal and added the example code, but changed the example to match the correct version of windows my machine has installed. I didn’t see any other example just lots of different versions of Windows to choose from.