Should I update my BIOS?

I have noticed my bios is from 2015

 UEFI: American Megatrends v: 5.6.5 date: 08/29/2015

I’ve only had the pc for a month, it came with Windows 10 but I never ran it, just loaded Manjaro on top of it.

However, my system works fine, Should I update the bios ???

And if so, how do I update it?
(only ever done that on Windows about 20 Yrs ago).

inxi -Faz
System:    Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A 
           parameters: BOOT_IMAGE=/vmlinuz-5.8-x86_64 root=UUID=92e8fabc-4db6-449c-9b7a-c086cdc01f73 rw rootflags=subvol=@ 
           quiet apparmor=1 security=apparmor udev.log_priority=3 
           Desktop: i3 4.18.2 info: polybar dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Laptop Mobo: INTEL model: CRESCENTBAY serial: <filter> UEFI: American Megatrends v: 5.6.5 date: 08/29/2015 
CPU:       Topology: Dual Core model: Intel Core i7-4650U bits: 64 type: MT MCP arch: Haswell family: 6 model-id: 45 (69) 
           stepping: 1 microcode: 26 L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 18365 
           Speed: 2792 MHz min/max: 800/3300 MHz Core speeds (MHz): 1: 2792 2: 2163 3: 2792 4: 2417 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel Haswell-ULT Integrated Graphics driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0a26 
           Display: x11 server: X.Org 1.20.9 driver: intel unloaded: modesetting alternate: fbdev,vesa display ID: :0 
           screens: 1 
           Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1013x285mm (39.9x11.2") s-diag: 1052mm (41.4") 
           Monitor-1: HDMI1 res: 1920x1080 hz: 60 dpi: 81 size: 600x340mm (23.6x13.4") diag: 690mm (27.2") 
           Monitor-2: HDMI2 res: 1920x1080 hz: 60 dpi: 81 size: 600x340mm (23.6x13.4") diag: 690mm (27.2") 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 5000 (HSW GT3) v: 4.5 Mesa 20.1.8 compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel Haswell-ULT HD Audio driver: snd_hda_intel v: kernel bus ID: 00:03.0 chip ID: 8086:0a0c 
           Device-2: Intel 8 Series HD Audio driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:9c20 
           Device-3: Intel USB PnP Sound Device type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 2-1:2 
           chip ID: 8086:0808 
           Sound Server: ALSA v: k5.8.11-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 v: kernel port: e000 bus ID: 02:00.0 
           chip ID: 10ec:8168 
           IF: enp2s0 state: down mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 v: kernel port: d000 bus ID: 03:00.0 
           chip ID: 10ec:8168 
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-3: Intel Centrino Advanced-N 6235 driver: iwlwifi v: kernel port: d000 bus ID: 04:00.0 chip ID: 8086:088e 
           IF: wlp4s0 state: up mac: <filter> 
Drives:    Local Storage: total: 1.13 TiB used: 51.47 GiB (4.5%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/sda vendor: Kingfast model: N/A size: 119.24 GiB block size: physical: 512 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: 1A0 scheme: GPT 
           ID-2: /dev/sdb vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB block size: physical: 4096 B logical: 512 B 
           speed: 3.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 2U scheme: GPT 
           ID-3: /dev/sdc type: USB model: Mass Storage Device size: 59.48 GiB block size: physical: 512 B logical: 512 B 
           serial: <filter> rev: 1.00 
           ID-4: /dev/sdd type: USB vendor: Generic model: STORAGE size: 14.43 GiB block size: physical: 512 B logical: 512 B 
           serial: <filter> rev: 9451 scheme: MBR 
           ID-5: /dev/sde type: USB model: MXT-USB Storage Device size: 29.72 GiB block size: physical: 512 B logical: 512 B 
           serial: <filter> rev: 1501 scheme: MBR 
Partition: ID-1: / raw size: 1.04 GiB size: 1.04 GiB (100.00%) used: 16.7 MiB (1.6%) fs: btrfs dev: /dev/sda3 
           ID-2: /boot raw size: 512.0 MiB size: 487.9 MiB (95.30%) used: 59.6 MiB (12.2%) fs: ext4 dev: /dev/sda2 
           ID-3: /home raw size: 60.23 GiB size: 60.23 GiB (100.00%) used: 13.67 GiB (22.7%) fs: btrfs dev: /dev/sda8 
           ID-4: /opt raw size: 2.05 GiB size: 2.05 GiB (100.00%) used: 163.8 MiB (7.8%) fs: btrfs dev: /dev/sda6 
           ID-5: /usr raw size: 22.00 GiB size: 22.00 GiB (100.00%) used: 8.02 GiB (36.4%) fs: btrfs dev: /dev/sda4 
           ID-6: /var raw size: 12.65 GiB size: 12.65 GiB (100.00%) used: 3.85 GiB (30.5%) fs: btrfs dev: /dev/sda9 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 9.77 GiB used: 4.0 MiB (0.0%) priority: -2 dev: /dev/sda10 
Sensors:   System Temperatures: cpu: 45.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 364 Uptime: 7h 42m Memory: 15.55 GiB used: 3.67 GiB (23.6%) Init: systemd v: 246 Compilers: gcc: 10.2.0 
           clang: 10.0.1 Packages: pacman: 1391 lib: 331 Shell: Bash v: 5.0.18 running in: urxvtd inxi: 3.1.05

Thx.

If it ain’t broke don’t fix it is the usual advice.

It’s possible new BIOS updates fixed vulnerabilities and improved stability, you can check on your mobo manufacturer website, same place you’ll get a new BIOS rom.

Some manufacturers have a windows utility that can do it for you, some give you a file you need to put on a FAT drive and select in your BIOS, some motherboards can boot from a USB drive with a file and update that way. Once again your manufacturer will have a guide.

Last time I updated my BIOS I had to re-install Linux, but your mileage may vary.

2 Likes

Can’t argue with that sentiment, I completely agree.

Just seeing what other folks think, but if I have to do it eventually I would rather do it now whilst I’m still in installation mode so to speak. :slight_smile:

Thanks for you help :+1:

Even though I hate almost all motherboard Vendors, I would recommend updating BIOS .

It can have fixed ACPI tables for example.
Also some vendors make it hard to update bios externaly and provides some ugly Windows binary and then when you nuke windows out of your system, might loose easy way to flash Bios then.

1 Like

Yeah, thanks,I think your right there. Probably need to put DOS on a stick if I do it. :confused:

Probably not, I never had to have a dos bootable USB to flash any BIOS.
What is the exact model of your laptop? The exact references can be found on the sticker on the bottom usually.

If you come to the conclusion there is an BIOS update and you want to install it have a look into Hiren’s BootCD:

https://www.hirensbootcd.org/

It could help you to establish a Windoze environment to install a firmware update without installing Windoze.

Thnx. It’s a KINGDEL PO5B-i7-465OU. Vendor site is of no help at all.

OK I don’t think you’ll find any BIOS update for this.

Well, In my experience it helps to update BIOS. I was running a very old BIOS and had sound problem (dummy output) on all kernels except 5.4xx. On the old BIOS my angular button (<>) did not work. However by updating it, it solved the sound problem, making sound option work on newer kernels, and the angular button got fixed.
There were also some security patches for Intel in the update.

So in my case, the BIOS update worked like a charm and solved two problems I was facing at the moment, but of course, your mile may wary.

Thanks you for all your help folks. :+1:

I can’t find anything out there that relates to my board, so…

I think I’ll let sleeping dogs lie and go with the “it’s not broken, don’t fix it” paradigm .
:slight_smile:

2 Likes