Shortkeys not working after update Gnome Wayland

In gnome settings, I configured custom shortkeys that stopped working after the last Manjaro update.

It’s a real issue because I have mapped Flameshot commands to PrintScreenKey, so I can’t take screenshots atm, which I do all the time :frowning:

After the update, the package manager yielded warnings that look like this.

Warning:glib: /usr/lib/localeC.utf8/LC_ADDRESS…
It has been backed up to /usr/lib/localeC.utf8/LC_ADDRESS.old

And a bunch of similar errors, not sure if it is related.

I tried changing the shortcuts to other keys, but it doesn’t help.

Other shortkeys still work e.g. SUPER+T to open terminal still works.

Any ideas?

If you had the old glibc-locales package from the extra repo installed, the update to the new core package will need manual intervention:

 sudo pacman -Syu glibc-locales --overwrite /usr/lib/locale/\*/\*

Assuming you read the [Stable Update 2023-10-09] announcement, you should have known this.

After that, you may (or may not) have to re-configure all of your custom shortkeys. Possibly, a reboot will be needed. Cheers.

I tried everything, your command too.
It’s just crazy.
Flameshot in the terminal works.
I think all other custom shortkeys work.
Just the shortkeys for Flameshot on PrntScr, or any other key combination for that matter, does not work.

I’m afraid I can’t help with Flameshot itsef. Good luck. :slightly_smiling_face:

I found a workaround.

I could see when I ran Flameshot from the terminal.

Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.

So, Flameshot works but needs that QT_QPA_PLATFORM variable to be wayland.

In Gnome custom shortkeys, I tried al of these and it didn’t work.

1. QT_QPA_PLATFORM=wayland && flameshot gui
2. QT_QPA_PLATFORM=wayland; flameshot gui
3. QT_QPA_PLATFORM=wayland in .zshrc

The actual workaround was to write a bash script and put it in $USER/.local/bin

  1. nano takescreenshotfull
  2. #!/bin/bash
    flameshot full --path <screenshots_dir>   #    ~ and $USER in <screenshots_dir> could cause issues
  3. chmod +x $USER/.local/bin/takescreenshotfull
  4. In Gnome custom shortkeys, fill in command field with takescreenshotfull

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.