Shortcut KRUNNER have conflict in VSCODE

Hi people, i’m using KRUNNER and my shortcut is: ctrl + space but when i’m coding and use my VSCode i can’t use the suggestion trigger because use the same shortcut.
I would like when i use VSCode the shortcut ctrl + space works in VSCode and not KRUNNER.
It is possible?

Thanks for read me! :slight_smile:

Simple set KRunner shortcut back to Alt+Space

I like the shortcut ctrl+Space for KRunner, maybe someone can find other solution better.

This is taken from and modified to work on kde 5.24.

Go to Settings > Workspace > Window Management > Window Rules and a new rule and replicate the below settings and Apply.


Note - If you are running code from official repos “Window class” will be code-oss. If it’s something from the AUR then open a terminal and your “VSCode” and type xprop and click on it. This will output the window class which you can use later.

Also note that this settings wiil disable all shortcuts except the vscode ones when vscode is active.

1 Like

It works!

Thanks :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.