Shortcut input fails


To add info that I’m using Microsoft SideWinder X4 keyboard with UK layout. Specifically, the Pipe / NOT / Grave key does not register as being pressed when trying to created shortcuts in KDE System Settings. This does work with the same physical keyboard on an identical Manjaro+KDE install on a different computer.

Original post:

I can’t seem to input keyboard shortcuts. When I select the box and then supposed to press the appropriate key(s) only some keys are recognised as input.

For example, I can set Esc to launch Yakuake, but not `

The same is true for setting custom/global.

New-ish to Linux, but my other Manjaro install has no issues like this. I’ve googled/searched here but can’t find anything that’s resolved things. I’ve tried changing the keyboard to a different input/layout, no joy. I’m using the same keyboard, with the same settings just fine on my other Manjaro desktop.

Any help appreciated.


Tried manually editing the files ~/.config/kglobalshortcutsrc to no avail.


Renamed the following hoping they’d be regenerated. Turns out they’re just replaced from memory prior to shutdown.


Have also posted in KDE forum, as I think it’s likely a KDE specific issue rather than Manjaro.

I don’t know anything about KDE, but can you turn off any ‘session-save’ settings?

Do you mean, don’t save the session to be continued next time?

The config files were still overwritten on a reboot :frowning:

Small update:

I’m now pretty sure this is a KDE specific issue. Using:

mhwd -lh -d --usb

Reference: Manjaro Hardware Detection - Manjaro


Left output is KDE+Manjaro running on mini-PC (X86 still). Right output is also Manjaro+KDE on my main desktop, on which the KDE Shortcuts functions perfectly.

Both computers ‘System Settings’ report:
Version 5.20.4

KDE Frameworks 5.76.0
Qt 5.12.2 (built against 5.15.1)
The xcb windowing system