Shortcut ctrl + shift + u not working in zsh terminal

Hello, how are you, I’m a newbie to Manjaro, I’m using the Manjaro kde terminal that comes with zsh by default, however when I want to insert special characters like the backslash using ctrl + shift + u it doesn’t work in zsh, how can I achieve that? (psta: my keyboard is 60% so it doesn’t have many keys so I have to handle the unicode characters, and I use Spanish distribution)

Welcome to the forum! :vulcan_salute:

Unfortunately, the traditional way of typing Unicode characters by way of the Ctrl+Shift+U + hex code does not work in qt-based applications. KDE Plasma and all of its components are qt-based.

I believe there’s a workaround by way of ibus, but I’m afraid I can’t give you any more details about that.

There was however a thread about it here at the forum that I myself participated in, but that I left behind because I had been wrong — it worked on my system, but only in gtk-based applications, not in qt-based applications — and because of the rather arrogant attitude of the original poster. Yet, the thread was marked as solved later, so perhaps you will find the necessary information there to make it work.



It does work in QT applications once you’ve added support.

Just install manjaro-asian-input-support-ibus, then log out and back in again.

sudo pacman -S manjaro-asian-input-support-ibus

This was the solution provided by @medmedin in the thread that @Aragorn linked to.


Excellent, I was reading a little and I think it hits the nail on the head, however, I have a question, what does manjaro-asian-input-support-ibus add to the keyboard layout? I am a newbie and I would like to understand a little more the reasons for the solution

pacman -Ql manjaro-asian-input-support-ibus

It doesn’t add anything to the keyboard layout, at least not directly.

The package installs ibus and 2 files. The first file defines some environment variables, the second auto-starts ibus.

export GTK_IM_MODULE=$im
export QT_IM_MODULE=$im
export XMODIFIERS=@im=$im
export INPUT_METHOD=$im
export SDL_IM_MODULE=$im

[Desktop Entry]
Exec=ibus-daemon -drx