Shaking cursor on a bluetooth mouse

Good afternoon everyone, how are you? I would like to ask for help with an issue I’ve been experiencing and it’s driving me crazy! I bought a Bluetooth mouse and keyboard from DELL about three months ago. The first time I used it, I thought it was okay, but after a while, I noticed that I was missing the buttons when trying to click, for example, the close tab button on the browser. The precision level of the mouse is very poor on Linux, I thought this could be a physical problem but I have a Windows laptop here and it works fine. I’ve attached an image below to illustrate how poor the precision is.

I have no idea what could be causing this problem. I’ve done several searches and I saw that it could be the battery, so I replaced the battery and the problem persists. I also saw something related to the boot not loading the drivers correctly, so I set the BIOS to default and disabled fast boot. I installed the manjaro-bluetooth package to see if it would solve the problem, but it didn’t help. I tried to enable or disable mouse acceleration, but also without success. I also tried to update or downgrade kernel (from 6.6 LTS to 5.10 LTS) Any tips on what I can do? I really appreciate any directions that I could take here.

inxi -Fxz
  Kernel: 6.8.0-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
  Desktop: GNOME v: 45.4 Distro: Manjaro base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: PRIME B450M-GAMING/BR v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 2006
    date: 11/13/2019
  Info: 6-core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+ rev: 2
    cache: L1: 576 KiB L2: 3 MiB L3: 16 MiB
  Speed (MHz): avg: 2798 high: 3792 min/max: 1550/3400 boost: enabled cores:
    1: 2258 2: 3537 3: 3400 4: 1685 5: 3791 6: 1685 7: 3792 8: 2493 9: 3791
    10: 1685 11: 3780 12: 1685 bogomips: 81468
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: XFX Pine driver: amdgpu v: kernel arch: GCN-4 bus-ID: 08:00.0
    temp: 51.0 C
  Device-2: A4Tech REDRAGON Live Camera driver: uvcvideo type: USB
    bus-ID: 3-1:2
  Display: x11 server: v: with: Xwayland v: 23.2.4 driver:
    X: loaded: amdgpu unloaded: modesetting,radeon dri: radeonsi gpu: amdgpu
    resolution: 1920x1080~60Hz
  API: EGL v: 1.5 drivers: radeonsi,swrast platforms:
    active: x11,surfaceless,device inactive: gbm,wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.2-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 570 Series (radeonsi
    polaris10 LLVM 16.0.6 DRM 3.57 6.8.0-1-MANJARO)
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: XFX Pine driver: snd_hda_intel v: kernel bus-ID: 08:00.1
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel bus-ID: 0a:00.3
  Device-3: FIFINE Microphones K670 Microphone
    driver: hid-generic,snd-usb-audio,usbhid type: USB bus-ID: 1-2:2
  Device-4: A4Tech REDRAGON Live Camera driver: uvcvideo type: USB
    bus-ID: 3-1:2
  API: ALSA v: k6.8.0-1-MANJARO status: kernel-api
  Server-1: JACK v: 1.9.22 status: off
  Server-2: PipeWire v: 1.0.3 status: active
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel port: f000
    bus-ID: 07:00.0
  IF: enp7s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
    v: 0.8 type: USB bus-ID: 1-4:4
  Report: btmgmt ID: hci0 rfk-id: 1 state: up address: <filter> bt-v: 5.1
    lmp-v: 10
  Local Storage: total: 447.13 GiB used: 199.15 GiB (44.5%)
  ID-1: /dev/sda vendor: Kingston model: SA400S37480G size: 447.13 GiB
  ID-1: / size: 438.75 GiB used: 199.15 GiB (45.4%) fs: ext4 dev: /dev/sda2
  ID-2: /boot/efi size: 299.4 MiB used: 296 KiB (0.1%) fs: vfat
    dev: /dev/sda1
  ID-1: swap-1 type: file size: 18 GiB used: 0 KiB (0.0%) file: /swapfile1
  System Temperatures: cpu: 63.9 C mobo: N/A gpu: amdgpu temp: 51.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 1133
  Memory: total: 24 GiB available: 23.39 GiB used: 6.67 GiB (28.5%)
  Processes: 363 Uptime: 18m Init: systemd
  Packages: 1254 Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: Zsh v: 5.9
    inxi: 3.3.33

this cambridge-bluetooth-adapter troubles often.
you can try to install

pamac install bluez-hid2hci

reboot and check.
there are also some settings like autoenable etc… that you can enable in
etc/bluetooth/main.conf. check the internet for the individual functions of this config-file.

p.s.: i had a similar usb-bluetooth adapter (hama) and it was a pain. it’s worth to replace this one with a more actual and accurate stick. this adapters aren’t so expensive but safe a lot of anger.

This package is installed already :smiling_face_with_tear:

bluez-hid2hci  5.72-2 [Installed]                                                                            extra
    Put HID proxying bluetooth HCI's into HCI mode

check /etc/mkinitcpio.conf for

#MODULES=(usbhid xhci...

uncomment it to

MODULES=(usbhid xhci_hcd....


sudo mkinitcpio -P
sudo update-grub

reboot, check and report please

Hey Olli, thanks for your answer. I did this but it didn’t help. Have been using for five days with no improvement of the shaking cursor.

But today things got a little worse, sometimes my mouse gets veeeeery slow for like 6 seconds and get back to normal, sometimes when I try to write a lettttttttttttttttttttttttttttter it repeats like this for like 1 or 2 seconds. The keyboard and the mouse share the same dongle. It’s a Dell KM5221W