Several button presses not being detected on Xbox 360 controller

I’m having a weird problem. I just went on a distro-hopping spree and didn’t experience it anywhere but Manjaro.

I have a wired 360 controller and if I push a button in a game; quite often it doesn’t register the button press. If I need to hit X, I can usually hit it 5 times a second, whereas here I’m only hitting it 3.

This is happening in a game right now in Steam. I don’t know if it is happening in other games (don’t have other controlller games) or outside of Steam.

But I do wish to reiterate that this wasn’t happening in Steam on other distros.

Does anyone know what could be going on?

Edit: An interesting data point: if I go to Settings and Input Devices, I can mash the buttons as quickly as possible and the inputs are detected.

It seems to be something related to that game/steam, but only in Manjaro.

As i’ve read elsewhere, some games don’t handle controllers well enough, so they use Steam as an interoperability layer. Check that Xbox Controller support is enabled in Steam’s settings.

If it still doesn’t work, check this:

As I said, the the game worked fine in other distros (using steam).

I went to the wiki page, and oculdn’t find anything obvious. Is there something specific I should be looking for?

Are you using the system libraries (package steam-native) ?

So I’m just using whatever is included by default in Manjaro. I never bothered looking which version it is.

I just checked it out and by default you have steam-Manjaro installed. So I am not using steam-native.

What is the difference between the two versions? Which one should I be using? I didn’t even know you could have multiple versions of steam.

steam-native makes Steam use the libraries installed on your system, rather than the ones bundled with.
I usually go without that package, since Steam works supposedly better with the libraries it provides. But in some cases, one may be interested in installing that package, thus using the supposedly up-to-date libraries, which may include fixes or new features. No risk giving it a try for your issue…

Seems like something worth exploring: so just uninstall steam-Manjaro and install steam-native?

Is it as simple as that, or do I have to install additional dependencies and packages?

For example, there’s an app called linux-steam-integration, do I need ot install taht as well?

So a few updates:

First I uninstalled steam-Manjaro; I also went to .local/share and and deleted the Steam folder. However reinstalling steam-native also required the installation of steam-manjaro.

I tried to launch only steam-native, however that doesn’t work. Steam just hangs an “updating Steam information” screen.

I quit steam-native and tried launching steam-manjaro which launches just fine. The game still has an input delay though.