Settings not opening in Budgie

I have moved my installation from xfce to Budgie and had a few problems. This is a single boot installation. After installing Budgie I got an error when trying to boot that put me into an emergency shell. I followed the instructions of tutorial: how to magically fix most computers that will not boot after manjaro update"

It worked a treat and I was able to boot into Manjaro Budgie. I immediately went to settings to set some things up. The settings appeared for about 30 seconds and then disappeared. Since then I have not been able to open settings at all. If I try to open them from the menu nothing happens. If I do a right click from the desktop and choose system settings, I get a spinning circle and then nothing happens.

I have searched about this and I ran pacman -Qk|grep warning. The result was a whole list of files where after the file, it said “permission denied”. I can post the whole list if helpful

I have tried changing some of these in File Manager to allow permission to all, but still no success. I wonder if when I used the tutorial above, the installation got confused and gave these permissions to the Live USB?

I have also updated the kernel to 5.15 but no change.

Any help would be greatly appreciated by this noob.

OK. So I reinstalled Budgie and had to go through the “tutorial” again as I got put into the emergency shell. Then I tried installing Cinnamon and the same happened. I’m wondering if I need to format my SSD and then install Budgie? Would that work?

Once in Budgie, I realised that it is when I click on “multitasking” within settings that causes settings to disappear and not execute when I try to open it.

Any help would be greatly appreciated.