Settings Manager says my kernel is unsupported, installs new one, but reboots to old?


Still relatively new to Manjaro, but not new to linux . . . end user for many years. I have a triple-boot set up on a '20 Sys76 Gaz15 laptop . . . today booted in Manjaro after running an upgrade over the weekend and I see a notification that, “Your colonel is old!!!” and another one that said, “Your colonel is unsupported, please upgrade to a newer fellow!!!”

So I launched the Setting manager and found the “Kernel” app and it listed the installed, running and now apparently “unsupported” kernel as . . . and it showed options for one 5.12 and one 5.13, and one “experimental” of 5.14 . . . . I chose the 5.12 to install and it went through w/o error reported. And, it also showed the grub menu items as refreshing. I rebooted and I went to grub menu “advanced options” for Manjaro and after logging in it still showed “5.11”??? I shut it down and cold booted, same process and back into 5.11.

I had some issue with the kernel upgrade process previously, so I looked at the forum and found that somebody else ref’d my old thread . . . saw something about “update-grub” . . . so I ran that again and it found the other two systems . . . shutdown and cold-booted and ran -uname -r and we’re still in 5.11??

So, the question is, why would the system “see” that 5.11 is “old and unsupported” and flash a notification and then if I use the GUI “Kernel” app to install a newer kernel . . . why is it not booting into that kernel or providing the option for it in advanced options menu item in grub??? For the most part I am running a stock system upgraded via “pacman -Syyu” . . . after I got the “Your colonel is unsupported” error I ran -Syyu and it said, “Nothing to do,” but Kernel app showed running and unsupported kernel and it had an “install” button to click for 5.12, the app shows it as “installed” . . . but where is it? It’s not showing up in uname -r . . . my colonel, my colonel where for art thou??

adjusted the title

Please get your nouns right, the word is kernel.

grub probably remembers the your “choice” from the last boot and boots up that same entry on your next boot. If you want to change that, press esc on boot to bring up the grub menu and make another choice.

Remove the old 5.11 manually (it’s EOL anyway and will lead to problems in the future):

$ sudo mhwd-kernel -r linux511

This will also lead to an update of the grub config file (and thus the grub menu at boot) and the new kernel will get booted without interaction.

1 Like

Check that you have kernel 512 installed with:

pamac search -i linux512

You can also check that the files are in place:

ls -al /boot

You should see four files about kernel 5.12 (there also other files in this folder):


When you execute update-grub, you should see that it founds your kernel 5.12


Thanks for the “adjustment” . . . that was a little linux “humor” at work . . . .

Sorry that I missed these posts, didn’t get any notification on them. So, I’ll have to try the “esc” in the grub menu, one issue with that is that there are several systems listed in grub; but something like that perhaps did fix this selecting new kernel problem that I ran into previously . . . . This time “update-grub” didn’t seem to.

As far as removing the 5.11 kernel goes, right now it still is the “running” kernel. And, in the Kernel app I tried to remove the old not-running 5.10 kernel via the app, and it “failed” to do that “because it would break dependencies” . . . . So, for now it doesn’t seem like 5.11 would just get up and go . . . ??


Thanks also for the post . . . I’ll check those commands when I get back to the Gaz15. The Kernel app shows that 5.12 is “installed” but isn’t “running.”

@et al:

So, this morning I booted my Manjaro Ornara 21.0.7 install in my '12 MacPro and I checked the kernel via uname -r and it was running 5.4.124-1 . . . . I checked the Kernel app and it showed the 5.11 option as viable and the 5.10.42-1 as “recommended.” I ran a pacman -Syyu and it showed 192 packages to upgrade, including a 5.4.131-1 . . . and in running it through, on reboot uname -r shows that slightly updated 5.4 kernel is running.

Point being that in both computers I have just run pacman to keep updated, but in one computer it’s running 5.11 and the system says it’s “unsupported,” but in the other machine it’s running 5.4 and it’s recommending 5.10 and 5.11 is also available and not identified as “old” or “unsupported” as it is in the newer machine.

Overall I am impressed with the efficiency of pacman upgrades but it seems like there is something around kernel upgrades that isn’t suave . . . it’s a tad rough in the presentation and handling . . . . I’ll post back when I’ve jumped over to the laptop and try out the suggestions provided here. Thanks.

sudo pamac search -i linux512
[sudo] password:
linux512 5.12.16-1 core
The Linux512 kernel and modules

[02@n-gazelle ~]$ ls -al /boot
total 141796
drwxr-xr-x  5 root root     4096 Jul 19 14:22 .
drwxr-xr-x 17 root root     4096 Jul 17 11:19 ..
drwx------  3 root root     4096 Dec 31  1969 efi
drwxr-xr-x  5 root root     4096 Jul 19 14:38 grub
-rw-r--r--  1 root root 28794910 Jul 17 11:19 initramfs-5.10-x86_64-fallback.img
-rw-r--r--  1 root root  7769190 Jul 17 11:19 initramfs-5.10-x86_64.img
-rw-r--r--  1 root root 28932744 Jul 17 11:19 initramfs-5.11-x86_64-fallback.img
-rw-r--r--  1 root root  7825252 Jul 17 11:19 initramfs-5.11-x86_64.img
-rw-r--r--  1 root root 31895409 Jul 19 14:22 initramfs-5.12-x86_64-fallback.img
-rw-r--r--  1 root root  7922089 Jul 19 14:22 initramfs-5.12-x86_64.img
-rw-r--r--  1 root root  4769792 Jun  8 11:31 intel-ucode.img
-rw-r--r--  1 root root       22 Jul 11 05:58 linux510-x86_64.kver
-rw-r--r--  1 root root       22 May 21 10:45 linux511-x86_64.kver
-rw-r--r--  1 root root       22 Jul 11 06:22 linux512-x86_64.kver
drwxr-xr-x  2 root root     4096 Jul 17 11:19 memtest86+
-rw-r--r--  1 root root  9412768 Jul 17 11:19 vmlinuz-5.10-x86_64
-rw-r--r--  1 root root  8280320 Jun 12 15:15 vmlinuz-5.11-x86_64
-rw-r--r--  1 root root  9539168 Jul 19 14:22 vmlinuz-5.12-x86_64
[02@n-gazelle ~]$ sudo update-grub
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.12-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.12-x86_64.img
Found initrd fallback image: /boot/initramfs-5.12-x86_64-fallback.img
Found linux image: /boot/vmlinuz-5.11-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.11-x86_64.img
Found initrd fallback image: /boot/initramfs-5.11-x86_64-fallback.img
Found linux image: /boot/vmlinuz-5.10-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.10-x86_64.img
Found initrd fallback image: /boot/initramfs-5.10-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Found Pop!_OS 21.04 (21.04) on /dev/nvme0n1p3
Found openSUSE Tumbleweed on /dev/nvme0n1p6
Adding boot menu entry for UEFI Firmware Settings ...
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.

[02@n-gazelle ~]$ uname -r

Grub “advanced options” doesn’t show 5.12 as an option.

I see that you have other Linuxes installed. Are you sure you are using Manjaro’s grub or is it one of the other’s Linux grub?

From what I see files are in place and update-grub correctly detects your kernels, so the only option is that grub is not using the grub config file generated in Manjaro.

Edit: Also kernels should show up in normal menu in addition to advanced menu

@non_space, please post your /etc/default/grub file.
Also, to make sure you are not using a non-Manjaro grub bootloader, restore your grub bootloader, completely.

I think these last two posts are on to the issue . . . using a “non-manjaro” grub bootloader. I think that what I did last time there was this kernel problem I had to run “os-prober” in opensuse, or something more complicated to get the latest Manjaro kernel update to show up in grub . . . ?? I’m over in the OEM install right now running an extended memtest to troubleshoot an issue in Pop!

But, this might explain why the Manjaro install in the MacPro is still back at 5.4 . . . I have more opensuse installs than I have manjaro installs . . . but, I do run various os-prober commands . . . but somehow “grub” isn’t paying attention.

I’ll post the requested /etc/default/grub file data when I get back over to Manjaro . . . possibly a few hours.

So, as I remembered, since it is opensuse that is in charge of grub, I ran Yast Bootloader “os-prober” and on reboot it found the newer Manjaro kernel and booted it. I ran your suggested “mhwd-kernel” command and it removed 5.11, but when I tried again to remove 5.10 . . . it refused???

sudo mhwd-kernel -r linux510

checking dependencies…
error: failed to prepare transaction (could not satisfy dependencies)
:: removing linux510 breaks dependency ‘linux510’ required by linux-latest
[02@n-gazelle ~]$ uname -r

Just remove linux-latest. It’s a meta-package.

OK, thanks kindly for the hint . . . still not up to speed on the commands in manjaro . . . “sudo -r linux-latest” ??? OR, sudo mhwd-kernel -r linux-latest ???

sudo pacman -R linux-latest but first of all why do you need to remove linux510? It is the latest stable kernel and usually the latest stable is what normal person would need.

UPD: yep, look down below :point_down:, thanks @freggel.doe

A small correction: it’s the latest LTS (the latest stable would be 5.13/5.12 depending on manjaro branch).

1 Like


Thanks for the commands . . . and the thoughts on saving 510 for a rainy day. It’s not that I have to remove 510, previously I was just trying to figure out how to get the system to move itself up to 512 . . . before I remembered that I had to run os-prober over in SUSE to get Manjaro to move up to the newly installed kernel . . . . And then I was just testing out the Kernel app to “install” and/or “remove” kernels, and then when it “resisted” removing 510 is when I wanted it gone . . . just because . . . . It’s just extra bloat in the system, etc. : -)


Thanks also for the comments about “stable” kernel . . . that install is now running 512. It does seem like the Manjaro care and feeding of kernels is a tad bit different than other linux systems I’ve played with in multi-boot situations. Like LM used to have a Kernel app, and the app would let you see the available kernels to add or remove, and the system installed them . . . I don’t recall where the master grub would be what then did or did not select them . . . for the system. Like in the case where the Manjaro install was holding at 5.4 kernel, when 510 was LTS available and there were 512/513 options . . . in a rolling distro??? Why was it up to something like 5.4-1334-1, when it could have moved itself up?

Anyway, I’ve got the drill down now, if I want to move up I now know how to get that done. Thanks kindly for the responses, much appreciated.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.