Setting up RDP (remote access) on Manjaro Raspberry Pi 4 tutorial?

Anyone have success at setting up an RDP server on Manjaro running on a Raspberry Pi 4 device? I’m quite impressed with how well Manjaro runs on this hardware, but I’m having some trouble getting other network devices to talk to a test FreeRDP server I’ve tried to execute via freerdp-shadow-cli. SSHD works great for other devices on the network in accessing this little server, but any test RDP connections immediately fire back a “Connection refused” message when using the correct IP:PORT for the server.

I’m simply attempting to mirror the active screens for remote access - nothing fancy.

what desktop?
what rdp/client viewer software? normally i use remminna to connect to my rpi4 vnc server, but i’ve taken that off line for now.
what device & software is the server running on.

In this case I have KDE via the Manjaro-ARM-kde-plasma-rpi4-21.04.img image.

I’ve tried connecting with Microsoft Remote on macOS, Remote Desktop on Windows, Jump Desktop RDP connection and rdesktop from the shell on macOS - all systems on the LAN and same subnet.

The real oddity is how FreeRDP is not giving any output on the console when running freerdp-shadow-cli via ssh on the rpi4 Manjaro server and trying to connect to it. A localhost connection via rdesktop does provoke output, however. This almost seems like freerdp-shadow-cli / FreeRDP is not listening to the correct interface, but it is listening on at the default 3389 port and no firewall is on (ufw isn’t even installed) AND as noted, ssh is fine.

Soooo, this is a bit peculiar and I’d normally think it would be a firewall config issue due to the way this is behaving and thus I was hoping to short circuit the diagnostic phase here with someone having compiled a tutorial / howto already that might reveal something particularly unique about the rpi4 img install that I might be missing. I usually run CentOS and Ubuntu on servers, but with the recent news on the RHEL+CentOS drama (and lack of official rpi4 support) and some headaches I’ve had with Ubuntu over the past year with another rpi4, Manjaro looked rather attractive…

As you seem to use other OSes, have you tried nomachine (aka nxserver)? It is in the AUR and there are downloads for Mac and Windows. It works pretty well, depending on your needs.

Hmm, well, we standardize on pretty much Jump Desktop which has VNC, RDP and of course their own protocol support… I usually find RDP smoother in other cases than VNC (plus usually existing copy/paste support vs quirks)… It is nice to be able to manage quite a number of systems cohesively and I haven’t wanted to add another protocol / app to the mix that will require additional considerations vs having the connections sync’d.