Setting up GTK file dialog size


There are always GTK apps, KDE or no. GTK file dialog can easily happen to be higher than your display, one has to do something with it. Now this question is absurdly complicated. I tried different approaches, nothing works. This solution via dconf partly works, sort of:

~> gsettings get org.gtk.Settings.FileChooser window-size
(1024, 768)

1024x768 is indeed the desired size and it won’t get overwritten. Unfortunately, the dialog is still substantially higher than my 768 pixels. It’s just as high as before, as a matter of fact. To be precise: I check the Save As dialog. Is it really FileChooser? If it’s something else, I can’t find the name. What can I try?

I use KDE with i3 as WM.