Setting language in Manjaro settings does nothing

i wanted to change my system to english language but with the numbers/metrics etc. of my country, with no success. To make it simple and go step by step i just changed everything to Irish which locale is pretty near to what i want. (en_IE.UTF-8)
What Manjaro settings do is change /etc/locale.conf and /etc/locale.gen and that looks ok.
After rebooting: a virtual console (crtl-alt-f2) is ok now, but not the xsession/xfce itself. It’s still complete in german, a “locale” in the terminal shows me de_DE.utf8.
I have no clue what the Manjaro settings are supposed to do but it does nothing to xfce itself. I could apply russian or suaheli here and nothing would change. What do i miss? my system is
stable branch.

Welcome to the forum!

Please see the following tutorial. :arrow_down:

Thanks i’ve read that before found with google.

  • my /etc/locale.conf is ok (only LANG=en_IE.UTF-8 in it)
  • my /etc/locale.gen is ok (what i need is uncommented
    and its new generated with locale-gen like 100 times
    the last 2 days, output is
    Generating locales…
    de_DE.UTF-8… done
    en_IE.UTF-8… done
    en_US.UTF-8… done
    Generation complete.
    Copying saved locales…
    Copying complete.

virtual console is ok (LANG=en_IE.UTF-8)
xsession/xfce is not ok (LANG=de_DE.utf8)

in Manjaro Settings Manager complete locale set to Irish, but it does nothing to xfce, it stays in de_DE.utf8 no matter what values i would apply here.
This is a fresh system i did not play around or broke
stuff i don’t understand why the Settings Manager is just not setting the language right for xfce.
Since the setting is working, but just not in the xsession, is there any other place i have to look? i’m going to try another desktop environment to check if its probably somewhere in X system or an xfce problem that i have.
As said before, this is an absolute fresh installed system which was initially installed with .de locale, now i want to change it to whatever and the settings manager does nothing.
The linux system itself is ok with my new locale setting.
I might even boot into a multiuser environment and “startx” to whatever i want then the locale should be ok.
Thats the funny part i dont get. X? lightdm? xfce? who is harassing me :frowning:

The settings manager usually works OOB - it has done so for years - so I don’t quite understand why a few users has issues.

You don’t mention your environment but from some of you dscription - although it is hard to read - and understand - references to xfce does pop out every now and then.

Xfce contains xml files with language settings.

No one is harassing you - check the system settings in xfce control panel

The settings manager(s) are a bit awkward to use - unintuitive is perhaps a better word.

the process:
LANG=C manjaro-settings-manager
→ Locale Settings → visit each tab
in “System Locales” you generate all the locales that you want
in “Detailed Settings” you have finer control over the components

That was the System part of it.

In the case of Xfce4 you go to it’s settings manager next.

LANG=C xfce4-settings-manager
go to “Keyboard” → “Layout” (third tab)

There is a switch at the top - you can leave it as is (in the “on” position)
Or you can switch it off and then set your own keyboard layout
add or remove layouts …

I have more than once struggled with this - it just would not change, then it would change after I rebooted not only once, but twice … it felt a bit like magic or woodoo :wink:

Just now I tried again - same thing, all settings correct, but no change in the UI.

Then I removed the ~/.cache folder with everything in it

rm -rf ~/.cache

no change

It seems to be a combination of:
choosing the correct setting before one logs in -
because that is another place where some language setting is offered - bottom right of login screen
and clearing the cache folder

and logging out and back in - but not only once …

It is a mess - no one can really understand it, it seems
there is the way that should work, but doesn’t - or only once the stars align in the proper way

It feels like a lottery.

I have managed to change back and forth between german and english UI - but I still don’t know the procedure that made it stick in the end
because there are three or four variables and I could not figure out the proper order of steps.

but you’ll succeed eventually - I believe in you :sunglasses: :muscle:

sorry, i was sure i posted this in /xfce and mentioned the word “xfce” 8 times.
Thought it would be clear this is about xfce.

not really, depending on whatever circumstances. As i mentioned this was an absolute fresh install, changing the language in the settings manager did nothing, even without trying to mix the LC* settings in the detailed settings. Just switching from de to us…not possible.

I made it work eventually (see answer to Nachlese, and his thoughts about that too…) with editing /etc/locales in a terminal and a reboot.

thanks for caring :grin:

edited /etc/locale.conf in a terminal


everything is fine now.

you know what linux proverb i really hate, from the day i first installed linux/redhat in 1999:
“your mileage may vary”