Setting a "wpa/wpa2 personal" for the network created by the plasma's "Hotspot" button succeeds but another device can connect without typing any password

I am connected to ethernet and I want to share it with another device tried some other solutions but only plasma’s ‘hotspot’ button worked for me,the problem is that by default it has no password and that isn’t good so I tried to edit the network I added “wpa/wpa2 personal” security set the password and it seems to save but the other device(android 10 phone) can connect without prompting for a password.
When I used wpa3 it didn’t show up at all.
Any help?
thank you,
have a nice day.

Have you tried deleting the hostspot and creating it with WPA/WPA2 again?

If yes: Could you walk us through the exact steps you took to come into this situation?

:thinking:

Sorry for the lte reply,
I don’t have plasma installed currently but as far as I know I created the hotspot with the button,
other manual steps I saw on the internet didn’t work.
Or do you mean I should remember the settings of the hotspot and recreate it?
Edit:I think I did the same steps more than once with the same output(clicked the button and set wpa/wpa2 personal )