Set system time format to "HH:mm:ss"

I would like to set this time format “HH:mm:ss” (06:23:59), with 24 hour clock and zero at left.
At “Preferencias del sistema” → “Región e idioma” → “Hora”, I can only choose from a list of presets by country, and none of the “Spanish” ones suits me. If I choose one with the desired time format, also changes the language (english instead of spanish) of some options in menus, wich is ugly.
Is it possible to define this custom time format?
This was possible before I updated the system yesterday, and it was just fine.

Assuming you’re talking about a digital clock on your panel, right click on that then select “configure digital clock”. This should allow you to adjust how the time’s shown there.

I had to make some changes there when I upgraded my test system to Plasma 6 yesterday, as the seconds display had vanished. And I’ll have to do the same on live in a couple of hours when I have an upgrade window.

1 Like

Thank you for your answer. The digital clock configuration only allows me to change the date format, but not the time format.
It only takes me to “Cambiar las preferencias regionales” wich is the same screen at “Preferencias del sistema”.

Strange. I wonder if we’re using different clock widgets. Unfortunately I can’t compare directly yet as I’m on a system still running Plasma 5.

If you select “Configure Digital Clock” by right clicking there should be an option for “Show Seconds” under the Appearance tab.
Select “Always” to show seconds on the clock.

In Digital Clock Settings, I suggest changing Time Display to 24-Hour, and Date Format to ISO Date.

Additionally, change Show Seconds to Always.

This should give you an approximation of what you describe.


En Configuración del reloj digital, sugiero cambiar la visualización de la hora a 24 horas y el formato de fecha a fecha ISO.

Además, cambie Mostrar segundos a Siempre. Esto debería darte una aproximación de lo que describes.

Yes, that is exactly how it is set up. Still not “HH:mm:ss” format, no zero at left.
Example: 6:57:15 instead of 06:57:15.

Change your regional settings to a Spanish that supports a 24-Hour format. Or, you could try Region & LanguageTime → Change to C.

Then, change the Digital Clock Settings as before.

The only ones seem to be Brazil and Belize, the format is ok but changes the language of some menu items to english. Same problem with the C option.

I have nothing further to suggest.

Sorry I missed the part where you were missing the preceding 0.

As of now I see no option for this.

But I can confirm that you can achieve this through the locale settings.

The already suggested C should work.

Yes, It works fine, the problem is, as I mentioned, it changes the language of some menu items, to english instead of spanish.

This may be something you need to take up with KDE Support. As it stands currently, the issue as defined by the thread title, is now solved.

Good luck.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.