Set Firefox to open full screen and no border

As in the title…

How do I set Firefox to open full screen and no border by default?

It seems on a reboot that the way it opens is somewhat random and sometimes even on setting no border the border bar space remains and a close and open is needed for it to behave as intended.

  1. Set a shortcut to run Firefox --kiosk (you could bind this also to a mouse gesture or keyboard shortcut).

  2. For KDE applications - I use this with Plex Media Player so that it has no border, forming a simple video tile which will fill the screen in tiling mode.

First you must enable the Titlebar…

Right click the titlebar and add a special window setting (right click the titlebar) and + Add Property then type ‘full’ to pull up the ‘Fullscreen’ property - then you can select ‘Apply Initially’ for a property which will only occur when you first launch Firefox - meaning you can window it or tile it later.

However, I can’t say that the way Firefox opens is - in any way - random… though I wouldn’t bother setting Firefox ‘no border’ because simply removing the titlebar leaves it with no border and it isn’t a KDE application.

1 Like

1 Like