Set dark theme on dolphin in cinnamon

Continuing the discussion from I cannot set dark theme on menu in dolphin Manjaro KDE plasma with Awesome WM:

I’ve installed those packages and then I’ve tried to use Qt5 Configuration Tool but it says The application is not configured correctly, and it doesn’t tell me how to configure it, so how do I configure it? And I haven’t touched it so why does it come with a bad configuration?

As it says in the arch wiki I’ve done export QT_QPA_PLATFORMTHEME="qt5ct" and added the line QT_QPA_PLATFORMTHEME="qt5ct" to my .zshenv file.

I believe setting the variables there only affect Zsh sessions, which means graphical sessions are unaffected.
You may need to set them in ~/.xprofile instead: Environment variables - ArchWiki

I already exported it anyways, so for now it should be working but I still see the same warning.

Maybe I have to restart.

Not sure why you tagged this cinnamon as it looks like kde?

I’m using cinnamon

Cinnamon uses “nemo” not “dolphin”

I’ve installed dolphin in cinnamon and I want to use it with a dark theme.

What is wrong with nemo? IMO nemo is better than dolphin.

I prefer nemo but I’m using dolphin as a tag based file manager which I can’t do with nemo. Having a white background keeps me from using dolphin for anything more than that.