Session doesn't start, Xorg doesn't start

Hi all,
I am very new to the issue at end.
Basically my manjaro session doesn’t start, I have a black screen.
I managed to use ctrl+alt+F2 to start a console and checked Xorg.1.log

I don’t have another computer to write here, so I apologise for the pictures.

There was a recent update with a massive amount of modules/packages been updated.
I also recently installed openshot to do video edition and simplescreenrecorder. It might be related.

As I said I don’t have any other computer, I am really hoping to find help to solve this.

I’ll provide any additional information needed just ask.

Thanks for any help.


1 Like

Pictures are fine in this case. Would be nice to know a little more about the graphics card you have. Since you can login to a console you have still access to the system.

You can try to see if some update was not fully done and initiate the update again:

sudo pacman -Syu

If you get more packages, try to update those too and then do another reboot.

You can check with mhwd -li which graphical drivers got installed and with mhwd which profiles for drivers are available. With the following you can try to install the free opensource drivers again:

sudo mhwd -a pci free 0300

You may replace free with nonfree if you want to install proprietary Nvidia drivers.

I had a similar problem after installing the latest stable release and upgrading to kernel 5.15. LightDM worked when booting kernel 5.10 but Xorg did not start when booting kernel 5.15 (I got the no screens found in /var/log/Xorg.0.log).

I followed the suggestion here LightDM - ArchWiki and that solved the problem for me. Try to add


to the [LightDM] section in /etc/lightdm/lightdm.conf

Hi guys, thanks for the replies, it appears that my graphics card drivers were incompatible with the latest xorg, simple as that. I found another driver and downgraded xorg and xorg-common, and it worked again, but not in the best way, resolution changed and several hiccups started appearing. According to guys on IRC #linux channel, it might be a fix for now but it’s a dead end on the long run.
Anyway thanks for the replies.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.