Sensors for fan control on Radeon 5500XT selectively unavailable?

I have the following problem with my graphics card (Radeon 5500XT):

Before configuring anything manually, the fan speed was handled by the card, but did not exceed 1000/min, which lead to overheat problems (sure took me a while to figure out why games kept knocking out the machine, sometimes, but sometimes not…).

While trying to find the issue, I ran sensors-detect to find the temperature readings for the GPU, and it found the following:

# sensors
Adapter: PCI adapter
Tctl:         +44.0°C  
Tdie:         +44.0°C  
Tccd1:        +38.2°C  
Tccd2:        +41.8°C  

Adapter: PCI adapter
vddgfx:        6.00 mV 
fan1:           0 RPM  (min =    0 RPM, max = 3400 RPM)
edge:         +37.0°C  (crit = +110.0°C, hyst = -273.1°C)
                       (emerg = +115.0°C)
junction:     +37.0°C  (crit = +105.0°C, hyst = -273.1°C)
                       (emerg = +110.0°C)
mem:           +0.0°C  (crit = +105.0°C, hyst = -273.1°C)
                       (emerg = +110.0°C)
power1:        3.00 W  (cap = 125.00 W)

So far so good. I have the case opened, and the fans are indeed not spinning.

When I then run pwmconfig, it starts by spinning the fans up to 100%, (very audibly),
but the fan speed sensor stays at 0, and pwmconfig aborts. The fans then keep spinning at 100% until I reboot the machine.

I thought that this might be an issue with the fan speed sensor (either directly, or due to it not being supported in some way), but when I boot from a live USB image (also Manjaro), the fan speed is detected and indicated without any issues, and the setup in pwmconfig continues. Unfortunately, it then fails to auto-detect the pwm setting at which the fans stop spinning. That is: it manages to turn them on or off, but not to ramp in between the extremes, so it stays at 100% during the auto-detect phase, until I use ctrl+c to abort (and then the fans stay at 100% until the next reboot…). On the live image, I can see how the fan speed ranges from 0 to 1000/min before running pwmcontrol, depending on temperature, and goes up to 3400 afterwards.

In the course of pinpointing the issue (there was also something wrong with the RAM configuration, also causing crashes, which obfuscated a lot), I have swapped graphics cards a few times, and also recently replaced the motherboard on the same system. This means that the sensor configuration has changed a few times, and there may be some leftover data from the removed hardware causing issues.

…and just to make matters more interesting, I also tried setting this up on a live openSUSE USB, and it also found the fan speed but claimed there was no PWM control device available – while still being able to switch fan speed up to 100%.

The question(s):

  • Where do I need to poke to get the installed system to find the correct fan sped sensor readings (must be possible since live Manjaro can do it)
  • If pwmcontrol can change the fan speed from 0 to 100%, does that not imply that it should also be able to do anything in between? If yes, how can I figure out what’s holding it back?

system info:

Not sure which inxi outputs may be relevant here, but for a starter, here’s some of them:

> inxi -F
  Host: monster Kernel: 5.13.19-2-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.26.2 Distro: Manjaro Linux
  Type: Desktop Mobo: ASUSTeK model: PRIME X570-P v: Rev X.0x
    serial: 210484331300543 UEFI: American Megatrends v: 3603 date: 03/20/2021
  Info: 12-core model: AMD Ryzen 9 5900X bits: 64 type: MT MCP cache:
    L2: 6 MiB
  Speed (MHz): avg: 2262 min/max: 2200/4950 cores: 1: 3700 2: 2200 3: 2200
    4: 2200 5: 2200 6: 2200 7: 2200 8: 2200 9: 2200 10: 2200 11: 2200 12: 2200
    13: 2200 14: 2200 15: 2200 16: 2200 17: 2200 18: 2200 19: 2200 20: 2200
    21: 2200 22: 2200 23: 2200 24: 2200
  Device-1: AMD Navi 14 [Radeon RX 5500/5500M / Pro 5500M] driver: amdgpu
    v: kernel
  Display: x11 server: X.Org v: 21.1.4 driver: X: loaded: amdgpu
    unloaded: modesetting,radeon dri: radeonsi gpu: amdgpu
    resolution: 1920x1200~60Hz
  API: OpenGL v: 4.6 Mesa 22.2.1 renderer: AMD Radeon RX 5500 XT (navi14
    LLVM 14.0.6 DRM 3.41 5.13.19-2-MANJARO)
Audio: [...]
Network: [...]
Drives:  [...]
Partition: [...]
Swap: [...]
  System Temperatures: cpu: 54.8 C mobo: N/A gpu: amdgpu temp: 35.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
  Processes: 506 Uptime: 39m Memory: 62.71 GiB used: 4.71 GiB (7.5%)
  Shell: Bash inxi: 3.3.23

Hello @Mr_Teatime :wink:

Maybe check this:

Could be possible, but not sure, that it switches to manual control for some unknown reason.

I recently moved to a rx 570 and I have found the fan control for AMD cards to be a bit wonky. Mine wouldnt turn the fan on. The nice thing is there are quite a few good applications for controlling the fan radeon-profile and radeon-profile-daemon-git are the ones I settled on. Its in the AUR. Highly recommended. You can get it to auto start in the tray and the fan curve is easy to setup.

1 Like

can you report

sudo mhwd-kernel -li

5.13.19 is very old and there no more support ( EOL )

I had the same problem with a Gigabyte 5500xt gpu in the past. In fact my fans weren’t spinning at all. I tried with pwmconfig and there on the contrary they turned completely without stopping. I found and used a software on aur which regulates my fans with small onions according to the temperature. I never managed to find and adjust these fans with lm sensors and its tools. Only amdfan available on aur solved the problem for me. You can find it here and follow all the process. At first look, now it seems not be available like it was in the past.

Hmmm, that’s weird because I ran pamac update today, and there does not seem to be a kernel update available (there were a few other things, so at least part of the update mechanism can’t be broken…) – which kernel should the latest version of Manjaro be using?

> sudo mhwd-kernel -li 
Currently running: 5.13.19-2-MANJARO (linux513)
The following kernels are installed in your system:
   * linux513

Just ran sudo pamac update again, and all it wants to do is update Python 2.7 …
This is a very different issue than what I started with – maybe I should open a new thread?

I’ve found this thread, but none of the suggestions there helped, neither using pacman nor pamac, and not even with Octopi.

Kernel 5.13 is no longer in the repositories or the settings manager. It must have been end of life 'd at some point. I recommend installing another kernel, 5.15 is good, its the latest LTS kernel. The choice is up to you, but Long Term Support kernels are best unless you need a newer one to support specific new hardware. Its also a good idea to have two kernels installed in case of a bad update or bug.

sudo mhwd-kernel -l

Will list all kernels available than you can install with the following line for sample the good choice 5.15 LTS.

sudo mhwd-kernel -i linux5.15

The next LTS kernel will be the 6.1 which will be available at the end of this month or the begining of the next.
Anyway, you must change of kernel and remove after this one. As I have already said and Jim.B too, Take a LTS like the 5.15 or later the 6.1 under if you need something very special in the kernel and Mesa like an Intel Arc Alchimist gpu. All will work fine. The 5.13 is EOL.

Funny story. I’ve been doing all my updates, like a good user should, and neither pamac nor pacman nor octopi wanted to update the kernel.

Just klicked the often-ignored (by me) Manjaro settings in the system tray, and found this (sorry, German interface, but you get the gist):

… so apparently some part of Manjaro knows it should get a new kernel, but none of the regular update routines are acting on it. Is there some setting I might have inadvertently set the wrong way? Don’t remember configuring anything to skip kernel updates or something like that.

I just clicked on “install” next to 5.15, and now it’s installing it. Hope I can evade that sort of surprise next time.

Tried Radeon-profile, and it works.
Probably a little more than I need because I only care about the fan speeds, not all the other bits. Had to set up the daemon through systemd, then put the client in my autostart, and now my fan curves are automatically applied and used. nice!

hmm… I miiight try reducing clock speed etc. for desktop work, do reduce power consumption and heat (thus noise). Not today, though.

I use the manual frequency control in the overclock section to reduce clock speeds. It does help offset the noise by lowering the heat. Radeon profile may be a bit much, but it has a lot of good features, like you I likely wont use it all.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.