Seems I can't get Broadcom BCM4369 802.11ac to work with my old MacBook

Hello there dear Manjaro crew!

I did the misstake of doing an install of Manjaro xfce on my old MacBook Pro (old Intel without GPU, 8GB RAM) and now I can’t get the wifi to work.

I had an old Manjaro running which I installed about 2-3 years ago where the network/wifi worked but I forgot the pwd so I thought I’d just do a quick install over that Manjaro partition and it would all work.

Blark, I can’t get the screenshot I took from the MacBook to get uploaded and I can’t find any other ways to show it :confused:

From the Manjaro settings manager/hardware config/ I see the Broadcom BCM4369 802.11ac adapter but I can’t click the “installed” on button/marking so I don’t know what to do.

I’m doing this from my old Huawei P20pro
Thanks and spanks in advance.

Hi @hobs0n, and welcome!

From what I can quickly gather, the b43 driver seems to be baked into the kernel, but it needs the b43-firmware to work. So try installing that, from the AUR:

pamac build b43-firmware

Hope it helps!


I see there is also the b43-fwcutter package in the extra repositorry:

$ pamac search b43
b43-fwcutter  019-4 [Installed]                                                                                                                                                                                                                          core
firmware extractor for the b43 kernel module

So you could try that and see if it works:

pamac install b43-fwcutter

However, I’m no expert, so I’m just taking a relatively educates guess 'bout that :man_shrugging:

Thanks for helping!

I found some other solution, I dont remember where but some place said that probably the default “driver” for Manjaro isnt working and gave me instructions for using another “driver” which worked :slight_smile:

I´m on another problem now, trying to learn how to install the stuff I need to mount the OsX APFS partition on the laptop

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.