Second Monitor not working after update

I am a noob and have been using Manjaro for about 2 months now. This morning I got a notification on the task bar that there were a few updates and I just ran all the updates, got coffee came back and now the second display monitor doesnt work anymore :(. I tried rebooting, booted into my other windows OS and works just fine. I even get the login screen on both monitors but when I log in the second display just goes blank and does not even show up on the display settings. I have a AMD Radeon RX 5500

I also tried reinstalling drivers. Hers is the result of my drivers


Installed PCI configs:

              NAME               VERSION          FREEDRIVER           TYPE

       video-linux            2018.05.04                true            PCI
 video-modesetting            2020.01.13                true            PCI

Warning: No installed USB configs!
~]$ glxinfo | grep OpenGL
OpenGL vendor string: X.Org
OpenGL renderer string: Radeon RX 5500 XT (NAVI14, DRM 3.39.0, 5.9.11-3-MANJARO, LLVM 11.0.0)
OpenGL core profile version string: 4.6 (Core Profile) Mesa 20.2.3
OpenGL core profile shading language version string: 4.60
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6 (Compatibility Profile) Mesa 20.2.3
OpenGL shading language version string: 4.60
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 20.2.3
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:

inxi -G
Device-1: AMD Navi 14 [Radeon RX 5500/5500M / Pro 5500M]
driver: amdgpu v: kernel
Display: x11 server: X.Org' 1.20.10 driver: amdgpu,ati
unloaded: modesetting,radeon resolution: 1920x1080~60Hz
OpenGL: renderer: Radeon RX 5500 XT (NAVI14 DRM 3.39.0


Spent about an hour on the internets trying to find solutions, but no luck. Would really appreciate if anyone has any ideas. I am guessing it has something to do with the updates. I wish I checked what the updates were before installing them. Alas.

Oh also, Im running Linux 5.9.11-3-MANJARO



Okay quick update.

This second monitor that is not working is using a Displayport to HDMI whereas the primary one is just HDMI on both ends. I got the second one to work after changing the resolution from 1920x1080 to 1440x900. So my primary one works at 1920x1090 and second one works at 1440x900. Not sure why it was working before and it doesnt anymore. But I guess its progress , but I still have to figure this out because ideally I would like both monitors to be at the same optimal resolution.

Anyway, if anyone has any ideas, please let me know.

Thanks again