Second Monitor not detected, but works fine with Windows

I have a dual boot system with Manjaro-i3wm and Windows 10. The second monitor doesn’t work with Manjaro, works with windows. It is not detecting the HDMI connection. Can someone please help.

Here is the the output of some commands:
xrandr

 kramer  ~  `xrandr` 
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 340mm x 190mm
   1920x1080     60.02*+  59.93  
   1680x1050     59.88  
   1400x1050     59.98  
   1600x900      60.00    59.95    59.82  
   1280x1024     60.02  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1368x768      60.00    59.88    59.85  
   1280x800      59.81    59.91  
   1280x720      59.86    60.00    59.74  
   1024x768      60.00  
   1024x576      60.00    59.90    59.82  
   960x540       60.00    59.63    59.82  
   800x600       60.32    56.25  
   864x486       60.00    59.92    59.57  
   640x480       59.94  
   720x405       59.51    60.00    58.99  
   640x360       59.84    59.32    60.00  
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

lspci

 kramer  ~  `lspci`
00:00.0 Host bridge: Intel Corporation 8th Gen Core Processor Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation 6th-10th Gen Core Processor PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation CoffeeLake-H GT2 [UHD Graphics 630]
00:08.0 System peripheral: Intel Corporation Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th/8th Gen Core Processor Gaussian Mixture Model
00:12.0 Signal processing controller: Intel Corporation Cannon Lake PCH Thermal Controller (rev 10)
00:14.0 USB controller: Intel Corporation Cannon Lake PCH USB 3.1 xHCI Host Controller (rev 10)
00:14.2 RAM memory: Intel Corporation Cannon Lake PCH Shared SRAM (rev 10)
00:14.3 Network controller: Intel Corporation Cannon Lake PCH CNVi WiFi (rev 10)
00:15.0 Serial bus controller: Intel Corporation Cannon Lake PCH Serial IO I2C Controller #0 (rev 10)
00:15.1 Serial bus controller: Intel Corporation Cannon Lake PCH Serial IO I2C Controller #1 (rev 10)
00:16.0 Communication controller: Intel Corporation Cannon Lake PCH HECI Controller (rev 10)
00:17.0 RAID bus controller: Intel Corporation 82801 Mobile SATA Controller [RAID mode] (rev 10)
00:1d.0 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #14 (rev f0)
00:1e.0 Communication controller: Intel Corporation Cannon Lake PCH Serial IO UART Host Controller (rev 10)
00:1f.0 ISA bridge: Intel Corporation HM470 Chipset LPC/eSPI Controller (rev 10)
00:1f.3 Audio device: Intel Corporation Cannon Lake PCH cAVS (rev 10)
00:1f.4 SMBus: Intel Corporation Cannon Lake PCH SMBus Controller (rev 10)
00:1f.5 Serial bus controller: Intel Corporation Cannon Lake PCH SPI Controller (rev 10)
01:00.0 VGA compatible controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GP107GL High Definition Audio Controller (rev a1)
06:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTL8411B PCI Express Card Reader (rev 01)
06:00.1 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 12)

I am not sure what is wrong, please help

Hi,

I’m just passing through but what does the following two commands do?

xrandr --listmonitors

sudo ddcutil detect

You must install ddcutil before with

yay -S ddcutil

sudo lspci -nnk | grep -i vga

 ~  xrandr --listmonitors

Monitors: 1
 0: +*eDP-1 1920/344x1080/194+0+0  eDP-1

sudo lspci -nnk | grep -i vga


00:02.0 VGA compatible controller [0300]: Intel Corporation CoffeeLake-H GT2 [UHD Graphics 630] [8086:3e9b]
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile] [10de:1c8c] (rev a1)

sudo lshw -C video


  *-display UNCLAIMED       
       description: VGA compatible controller
       product: GP107M [GeForce GTX 1050 Ti Mobile]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:a3000000-a3ffffff memory:90000000-9fffffff memory:a0000000-a1ffffff ioport:4000(size=128) memory:a4080000-a40fffff
  *-display
       description: VGA compatible controller
       product: CoffeeLake-H GT2 [UHD Graphics 630]
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list
       configuration: driver=i915 latency=0
       resources: irq:136 memory:a2000000-a2ffffff memory:b0000000-bfffffff ioport:5000(size=64) memory:c0000-dffff

sudo ddcutil detect

No /dev/i2c devices exist.
ddcutil requires module i2c-dev.

I am guessing it is a driver issue, since lshw -C video showed ones unclaimed

I think you have to install the Nvidia drivers because the HDMI connector is probably connected to it.

@mithrial Maybe, because lshw -C video outputs one unclaimed. However, I have installed nvidia drivers, not sure what’s wrong.
I installed from the GUI utility provided in Settings manager, also using sudo mhwd -a pci nonfree 0300.

2 things :thinking:

xrandr --listproviders

sudo ddcutil detect

No /dev/i2c devices exist.
ddcutil requires module i2c-dev.

Strange. You have not installed ddcutil either you 'll get an output like this one (but for one monitor for the moment). Install i2c-devices and try again.

sudo ddcutil detect
Display 1
I2C bus: /dev/i2c-8
DRM connector: card0-DP-3
EDID synopsis:
Mfg id: ACI - Ancor Communications Inc
Model: PA248
Product code: 9393 (0x24b1)
Serial number: C5LMQS104603
Binary serial number: 16843009 (0x01010101)
Manufacture year: 2012, Week: 21
VCP version: 2.0

I suspect an issue/conflict with intel/nvidia drivers. That really strange that we only see one DP port.
To my mind, I think that your second monitor is on the nvidia card and like it is intel the master it is normal to see only monitor. The solution is to desactivate intel.
Perhaps with Prime ?

Another question: are you using a displaylink device (the second monitor) ?

xrandr --listproviders

Providers: number : 1
Provider 0: id: 0x42 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 3 outputs: 1 associated providers: 0 name:modesetting

I am having errors installing i2cdev. When I try to make the files, I get make[1]: *** [Makefile:709: install-am] Error 2 . Not sure why.

I do think it is some problem with drivers. I will try shifting to only NVIDIA drivers using optimus prime or prime as you suggested.
Optimus Prime says nvidia module does not seem to be available for the current kernel.

Who? :thinking:

What? :thinking:

:point_down: :wink:

All that is necessary is to add users who will use ddcutil to group i2c:

$ sudo usermod <user-name> -aG i2c

I2C Device Permissions - ddcutil Documentation

EDIT: Also see Kernel Module Configuration - ddcutil Documentation

I added the line i2c_dev to /etc/modules-load.d/modules.conf, and when I now do sudo ddcutil detect
I get:

sudo ddcutil detect
Unable to open directory /sys/bus/i2c/devices/i2c--1: No such file or directory
Device /dev/i2c-255 does not exist. Error = ENOENT(2): No such file or directory
/sys/bus/i2c buses without /dev/i2c-N devices: /sys/bus/i2c/devices/i2c-255
Driver i2c_dev must be loaded or builtin
See https://www.ddcutil.com/kernel_module
Invalid display
   I2C bus:  /dev/i2c-7
   DRM connector:           card0-eDP-1
   EDID synopsis:
      Mfg id:               LGD - UNK
      Model:                
      Product code:         1496  (0x05d8)
      Serial number:        
      Binary serial number: 0 (0x00000000)
      Manufacture year:     2018,  Week: 0
   DDC communication failed
   This is an eDP laptop display. Laptop displays do not support DDC/CI.

@Cenwen

may you post the output of

inxi --admin --verbosity=7 --filter --no-host --width

and

primeinfo | grep server        (you need to install mesa-utils first if it's not installed)

laptop with hybrid and the sgi-driver isn’t friendly ? I guess but please post the output of this 2 commands.

@Olli

inxi --admin --verbosity=7 --filter --no-host --width

inxi - Pastebin.com (since the file is long)

primeinfo | grep server

No command found
Installed mesa-utils, it installed prime-offload and prime-switch only

sorry my mistake

glxinfo | grep server

and it will show up SGI (intel) on a typical acer-BS-nightmare laptop (welcome i use a predator of this same :poop:-company)

Haha, man the build quality is so :poop:, my laptop display is about to give in, that’s why I bought a monitor. :pensive:


glxinfo | grep server
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:

are you able to edit a textfile with sudo-rights ? if not we’ll help you.
what i really recommend to you is to switch to nvidia permanently. in this case i’m 100% sure it will work. it seem’s that acer really uses some electrical engineers that don’t know their job and that causes always trouble with this hybrid-mode-acer-BS.
if you want please install optimus-manager from the package-manager, but only installing this packet, do not switch anything that eventually will break your system. let me know if you want to try this.

I tried switching to NVIDIA using optimus. However, I get nvidia module does not seem to be available for the current kernel. when switching. i tried trying a new kernel(not real time), but still nothing changes.
On top of that, when I switch to NVIDIA, it starts the session but optimus manager is not able to open when NVIDIA is selected. I did the mistake of starting optimus on NVIDIA on boot, so now I am not able to even open optimus.

optimus-manager

ERROR: the latest GPU setup attempt failed at Xorg pre-start hook.
Log at /var/log/optimus-manager/switch/switch-20220820T120049.log
Cannot execute command because of previous error

Yes, I have the sudo rights

as i already warned you, do not switch anything ! please post the output of

systemctl status optimus-manager

I hope I haven’t broken anything

well optimus-manager is active, that’s fine. now you check with

echo $XDG_SESSION_TYPE

that it is x11. it is, but you should know that nvidia and wayland is a mess, always use x11.
after you checked this you will edit /etc/default grub . you will find a entry

GRUB_CMDLINE_LINUX_DEFAULT="

you will add to the existing entries the following two one’s

optimus-manager.startup=nvidia nvidia_drm.modeset=1

you need sudo-rights to edit this file. after succesful editing you will run the following commands

sudo update-grub
sudo mkinitcpio -P

after running this commands do a reboot.
if everything is fine you will enable another useful service

sudo systemctl enable nvidia-persistenced

you can reboot or

sudo systemctl start nvidia-persistenced

from here you have a working nvidia-setting and you can play around.

Did everything until mkinitcpio.
Afterwards, nvidia-persistenced not found

which nvidia-persistanced
which: no nvidia-persistanced in

My neofetch is still:

CPU: Intel i7-8750H (12) @ 2.200GHz
GPU: NVIDIA GeForce GTX 1050 Ti Mobile
GPU: Intel CoffeeLake-H GT2 [UHD Graphics 630]

what’s the output of

nvidia-smi | grep Driver