Second monitor goes black when fullscreening an application

I had manjaro installed, but the fact I couldn’t full screen a window on my second monitor really bothered me. I just reinstalled and my second monitor still has this issue.

If I fullscreen a video on my second monitor (whichever monitor isn’t set to primary in nvidia-settings), I can get out, audio continues to play and my cursor can still move around, but the screen just shows black.

It happens in firefox and discord (so I’m assuming everything else) The two fixes I have are to disable full-screen-api.ignore-widgets in firefox (only helps firefox naturally) or not maximize the window before fullscreening (which is pretty annoying).

What I’ve tried so far:
-Nouveu drivers DO work (but don’t work with the android studio emulator or have cuda, so I can’t use them)
-disabling KDE full screen animations does not help
-I tried installing the nvidia drivers from the official website, but this was giving me a lot of issues.
-I tried shifting to kernel 5.14 from 13, but the problem is still there.

Most solutions I’ve found online center around nvidia hybrid graphics (which I’m not using), so if anyone has any solutions, I’d appreciate it!


System specs:

  Kernel: 5.14.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.14-x86_64 
  root=UUID=5713985e-a16d-4540-860f-464cd0f30ae7 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop Mobo: ASUSTeK model: PRIME A320M-K v: Rev X.0x 
  serial: <filter> UEFI: American Megatrends v: 5406 date: 11/13/2019 
  Message: No system battery data found. Is one present? 
  RAM: total: 31.29 GiB used: 3.36 GiB (10.7%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP arch: Zen+ 
  family: 17 (23) model-id: 8 stepping: 2 microcode: 800820D cache: L2: 4 MiB 
  bogomips: 118202 
  Speed: 2425 MHz min/max: 2200/3700 MHz boost: enabled Core speeds (MHz): 
  1: 2425 2: 2069 3: 1796 4: 2038 5: 1877 6: 3367 7: 1993 8: 1957 9: 2087 
  10: 2083 11: 1927 12: 3373 13: 1994 14: 1993 15: 2523 16: 1782 
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 
  bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb cpuid 
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid 
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb irperf lahf_lm lbrv lm mca 
  mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl 
  npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq pdpe1gb 
  perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse pse36 
  rapl rdrand rdseed rdtscp rep_good sep sev sev_es sha_ni skinit smap smca 
  sme smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 succor svm svm_lock syscall 
  tce topoext tsc tsc_scale v_vmsave_vmload vgif vmcb_clean vme vmmcall wdt 
  xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GM206 [GeForce GTX 960] vendor: Micro-Star MSI 
  driver: nvidia v: 470.63.01 alternate: nouveau,nvidia_drm bus-ID: 08:00.0 
  chip-ID: 10de:1401 class-ID: 0300 
  Device-2: ARC Camera type: USB driver: snd-usb-audio,uvcvideo bus-ID: 1-9:4 
  chip-ID: 05a3:9331 class-ID: 0102 serial: <filter> 
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: 
  loaded: nvidia display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 3360x1080 s-dpi: 89 s-size: 959x315mm (37.8x12.4") 
  s-diag: 1009mm (39.7") 
  Monitor-1: DVI-I-0 res: 1440x900 hz: 60 dpi: 90 size: 408x255mm (16.1x10.0") 
  diag: 481mm (18.9") 
  Monitor-2: HDMI-0 res: 1920x1080 hz: 60 dpi: 92 size: 531x299mm (20.9x11.8") 
  diag: 609mm (24") 
  OpenGL: renderer: NVIDIA GeForce GTX 960/PCIe/SSE2 v: 4.6.0 NVIDIA 470.63.01 
  direct render: Yes 
  Device-1: NVIDIA GM206 High Definition Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus-ID: 08:00.1 chip-ID: 10de:0fba 
  class-ID: 0403 
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus-ID: 0a:00.3 chip-ID: 1022:1457 class-ID: 0403 
  Device-3: ARC Camera type: USB driver: snd-usb-audio,uvcvideo bus-ID: 1-9:4 
  chip-ID: 05a3:9331 class-ID: 0102 serial: <filter> 
  Sound Server-1: ALSA v: k5.14.2-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.35 running: yes 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel port: f000 
  bus-ID: 06:00.0 chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB 
  driver: btusb v: 0.8 bus-ID: 1-3:2 chip-ID: 0a12:0001 class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 1.61 TiB used: 186.82 GiB (11.3%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital 
  model: WDS256G1X0C-00ENX0 size: 238.47 GiB block-size: physical: 512 B 
  logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> 
  rev: B35500WD temp: 70.8 C scheme: GPT 
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LX015-1U7172 
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  type: HDD rpm: 5400 serial: <filter> rev: SDM1 scheme: MBR 
  ID-3: /dev/sdb maj-min: 8:16 type: USB model: MILAN II 512G size: 476.91 GiB 
  block-size: physical: 4096 B logical: 512 B type: SSD serial: <filter> 
  rev: 1012 scheme: GPT 
  Optical-1: /dev/sr0 vendor: ATAPI model: iHAS124 F rev: CL07 
  dev-links: cdrom 
  Features: speed: 48 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
  ID-1: / raw-size: 238.17 GiB size: 233.38 GiB (97.99%) 
  used: 41.17 GiB (17.6%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
  label: N/A uuid: 5713985e-a16d-4540-860f-464cd0f30ae7 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  label: NO_LABEL uuid: 46D5-D9AE 
  ID-3: /run/media/noahr/Initial raw-size: 931.51 GiB 
  size: 931.51 GiB (100.00%) used: 105.84 GiB (11.4%) fs: exfat dev: /dev/sda1 
  maj-min: 8:1 label: Initial uuid: A9E8-44FA 
  ID-4: /run/media/noahr/external_hardrive raw-size: 426.9 GiB 
  size: 426.9 GiB (100.00%) used: 15.04 GiB (3.5%) fs: btrfs dev: /dev/sdb2 
  maj-min: 8:18 label: external_hardrive 
  uuid: 47ecfea9-b457-4d3c-b6ba-f2976de37ecb 
  ID-5: /run/timeshift/backup raw-size: 50 GiB size: 48.91 GiB (97.83%) 
  used: 24.76 GiB (50.6%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17 label: Backups 
  uuid: 1c05555e-1b7e-4ee3-8f40-56b52d20f639 
  Alert: No swap data was found. 
  Message: No unmounted partitions found. 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 9 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-3:2 info: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) 
  type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  power: 100mA chip-ID: 0a12:0001 class-ID: e001 
  Device-2: 1-5:3 info: Sony WF-SP800N type: HID driver: hid-generic,usbhid 
  interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 500mA chip-ID: 054c:0d52 
  class-ID: 0300 
  Device-3: 1-9:4 info: ARC Camera type: Video,Audio 
  driver: snd-usb-audio,uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s 
  power: 200mA chip-ID: 05a3:9331 class-ID: 0102 serial: <filter> 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 3 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 3-3:2 info: Cooler Master MK750 type: Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s 
  power: 100mA chip-ID: 2516:0067 class-ID: 0300 
  Device-2: 3-4:3 info: Razer USA DeathAdder Essential type: Mouse,Keyboard 
  driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s 
  power: 500mA chip-ID: 1532:006e class-ID: 0300 
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Device-1: 4-1:2 info: Western Digital My Passport SSD (WDBK3E) 
  type: Mass Storage driver: uas interfaces: 1 rev: 3.1 speed: 5 Gb/s 
  power: 896mA chip-ID: 1058:25f3 class-ID: 0806 serial: <filter> 
  System Temperatures: cpu: 45.0 C mobo: N/A gpu: nvidia temp: 43 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
  Processes: 353 Uptime: 2h 49m wakeups: 0 Init: systemd v: 249 
  tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 1392 
  pacman: 1379 lib: 353 flatpak: 0 snap: 13 Shell: Zsh v: 5.8 default: Bash 
  v: 5.1.8 running-in: yakuake inxi: 3.3.06 

xrandr, if it helps

xrandr                                                                                                               ✔  3s  
Screen 0: minimum 8 x 8, current 3360 x 1080, maximum 16384 x 16384
DVI-I-0 connected 1440x900+0+90 (normal left inverted right x axis y axis) 408mm x 255mm
   1440x900      59.89*+  74.98  
   1280x1024     75.02    60.02  
   1280x960      60.00  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    60.32    56.25  
   640x480       75.00    59.94  
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 1920x1080+1440+0 (normal left inverted right x axis y axis) 531mm x 299mm
   1920x1080     60.00*+  59.94    50.00    60.05    60.00    50.04  
   1680x1050     59.95  
   1600x900      60.00  
   1280x1024     75.02    60.02  
   1280x800      59.81  
   1280x720      60.00    59.94    50.00  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    59.94    59.93  
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
DP-4 disconnected (normal left inverted right x axis y axis)
DP-5 disconnected (normal left inverted right x axis y axis)

Have you tried an LTS kernel already???


Unrelated yo your current issue:

but please read this!

I have tried an LTS kernel yeah, sorry I should have wrote that down as well.

And thanks for pointing out SWAP.

Can you post the content of your ~.nvidia-settings-rc file, please?


# /home/noahr/.nvidia-settings-rc
# Configuration file for nvidia-settings - the NVIDIA X Server Settings utility
# Generated on Sun Sep 19 21:58:30 2021

# ConfigProperties:

RcFileLocale = C
DisplayStatusBar = Yes
SliderTextEntries = Yes
IncludeDisplayNameInConfigFile = No
ShowQuitDialog = Yes
UpdateRulesOnProfileNameChange = Yes
Timer = Memory_Used_(GPU_0),Yes,3000
Timer = Thermal_Monitor_(GPU_0),Yes,1000
Timer = PowerMizer_Monitor_(GPU_0),Yes,1000

# Attributes:

  1. Create a new user if you don’t have a backup user or don’t know how to log into TTY2

  2. Between 0/FSAAAppEnhanced=0 and 0/ShowGSYNCVisualIndicator=0 can you add the following 2 parameters:

  3. Log off

  4. Log back on

  5. Try again.

I added the lines on my test user, logged out and logged back in but it was still happening

Well, can’t find anything else I’ve set in my .nvidia-settings-rc that you don’t have already and I don’t have your problem, so I’m all fresh out of ideas.


Absolutely heartbraking

Thanks for trying anyways, I appreciate it!

1 Like

Hello there!

While this is not a true solution, it may work. Try to use Wayland. Install this:

pamac install plasma-wayland-session

Afterwards (may need to restart) you may be able to select Wayland in the KDE login menu in the dropdown menu.