Sddm turn off screen when idle

In KDE / Power Management / Energy Saving, no checkbox is checked, i.e. screen is always on, it works after logging in.
But in login screen (sddm), the screen will turn off when being idle for some time, about 1 minutes or so.
How not to turn off screen automatically in login screen?

In power management - there are three tabs at the top. AC/Battery/LowBattery. All have options. Did you ensure that all are set at what you want?

Also check Workspace behavior → Screen locking
Locking the screen is different from SDDM, and it is different from power management

Every option has been taken care.

Sorry, I can’t test it now, I have switched to Windows.
Maybe I’ll test it later, thanks all the same.

Probably the settings you change in System Settings are saved to your user, which you are not logged in to in the SDDM screen so your settings are not loaded I guess? Maybe try to look for SDDM specific settings in /etc/ or maybe other system wide setting like in Xorg?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.