SDDM no response from keyboard & trackpad after stable-update

After I update my system, my computer boots, I can see SDDM screen, but I cannot use my keyboard or my trackpad. Nor can I use a USB-mouse, everything is dead-useless.
So I reverted back to pre-update state using Timeshift.

Then I realized I was using forked version of libinput & xorg-xf86-input-libinput. I thought to myself this could be the reason why I’m having a problem. I reinstalled the default package using “sudo pacman -S libinput xorg-xf86-input-libinput”. Rebooted, everything was working.
Then I updated my system again, and voila, everything is dead again: No response from keyboard or trackpad.

So once again, I used Timeshift and restored my system to pre-update state. I am sharing all the logs from pre-update state, which is the current state of my system.

Please help me to solve my problem.

  Kernel: 5.10.93-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
    root=UUID=5aa960f9-3052-4c76-9257-1057f04b9522 rw quiet
    resume=UUID=3af4b3a6-4df6-4288-ae08-99df3959dc81 udev.log_priority=3
  Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 wm: kwin_wayland vt: 2 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Apple product: MacBookAir6,2 v: 1.0
    serial: <superuser required> Chassis: type: 10 v: Mac-7DF21CB3ED6977E5
    serial: <superuser required>
  Mobo: Apple model: Mac-7DF21CB3ED6977E5 v: MacBookAir6,2
    serial: <superuser required> UEFI: Apple v: date: 06/10/2020
  ID-1: BAT0 charge: 33.6 Wh (100.0%) condition: 33.6/54.3 Wh (61.8%)
    volts: 8.2 min: 7.6 model: SMP bq20z451 type: Li-ion serial: N/A
    status: Full cycles: 2682
  RAM: total: 3.78 GiB used: 2.62 GiB (69.2%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i5-4250U bits: 64 type: MT MCP arch: Haswell
    family: 6 model-id: 0x45 (69) stepping: 1 microcode: 0x26
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1233 high: 1300 min/max: 800/2600 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1300 2: 1300 3: 1300
    4: 1034 bogomips: 15204
  Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2
    bts clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht ibpb ibrs ida invpcid invpcid_single lahf_lm lm mca mce
    md_clear mmx monitor movbe msr mtrr nonstop_tsc nopl nx pae pat pbe pcid
    pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand
    rdtscp rep_good sdbg sep smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp
    syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi
    vpid x2apic xsave xsaveopt xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Apple driver: i915
    v: kernel bus-ID: 00:02.0 chip-ID: 8086:0a26 class-ID: 0300
  Display: wayland server: X.Org compositor: kwin_wayland driver:
    loaded: modesetting alternate: fbdev,vesa display-ID: :1 screens: 1
  Screen-1: 0 s-res: 1440x900 s-dpi: 96 s-size: 381x238mm (15.0x9.4")
    s-diag: 449mm (17.7")
  Monitor-1: XWAYLAND0 res: 1440x900 hz: 60 dpi: 126
    size: 290x180mm (11.4x7.1") diag: 341mm (13.4")
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel Haswell-ULT HD Audio vendor: Apple driver: snd_hda_intel
    v: kernel bus-ID: 00:03.0 chip-ID: 8086:0a0c class-ID: 0403
  Device-2: Intel 8 Series HD Audio driver: snd_hda_intel v: kernel
    bus-ID: 00:1b.0 chip-ID: 8086:9c20 class-ID: 0403
  Device-3: Broadcom 720p FaceTime HD Camera driver: facetimehd v: kernel
    bus-ID: 02:00.0 chip-ID: 14e4:1570 class-ID: 0480
  Sound Server-1: ALSA v: k5.10.93-1-MANJARO running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: JACK v: 1.9.20 running: no
  Sound Server-4: PulseAudio v: 15.0 running: yes
  Sound Server-5: PipeWire v: 0.3.43 running: yes
  Device-1: Broadcom BCM4360 802.11ac Wireless Network Adapter vendor: Apple
    driver: wl v: kernel modules: bcma bus-ID: 03:00.0 chip-ID: 14e4:43a0
    class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Apple Bluetooth USB Host Controller type: USB driver: btusb v: 0.8
    bus-ID: 1-3.3:6 chip-ID: 05ac:828f class-ID: fe01
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 113 GiB used: 82.63 GiB (73.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Apple model: SSD SM0128F size: 113 GiB
    block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: SSD
    serial: <filter> rev: EA1Q scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 104.39 GiB size: 102.19 GiB (97.89%)
    used: 82.47 GiB (80.7%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: 5aa960f9-3052-4c76-9257-1057f04b9522
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 150.4 MiB (50.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL
    uuid: 9585-07E1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.31 GiB used: 12.2 MiB (0.1%)
    priority: -2 dev: /dev/sda3 maj-min: 8:3 label: swap
    uuid: 3af4b3a6-4df6-4288-ae08-99df3959dc81
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 9 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-3:2
    info: Broadcom BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth) ports: 3
    rev: 2.0 speed: 12 Mb/s power: 94mA chip-ID: 0a5c:4500 class-ID: 0900
  Device-1: 1-3.3:6 info: Apple Bluetooth USB Host Controller
    type: Bluetooth driver: btusb interfaces: 4 rev: 2.0 speed: 12 Mb/s
    chip-ID: 05ac:828f class-ID: fe01
  Device-2: 1-5:3 info: Apple Apple Internal Keyboard / Trackpad
    type: HID,Keyboard,Mouse driver: apple,bcm5974,usbhid interfaces: 3 rev: 2.0
    speed: 12 Mb/s power: 500mA chip-ID: 05ac:0291 class-ID: 0301
    serial: <filter>
  Hub-3: 2-0:1 info: Super-speed hub ports: 4 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Device-1: 2-3:2 info: Apple Internal Memory Card Reader type: Mass Storage
    driver: usb-storage interfaces: 1 rev: 3.0 speed: 5 Gb/s power: 896mA
    chip-ID: 05ac:8406 class-ID: 0806 serial: <filter>
  System Temperatures: cpu: 61.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 213 Uptime: 15m wakeups: 2 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 1601 pacman: 1586 lib: 384
  flatpak: 15 Shell: Zsh v: 5.8 running-in: yakuake inxi: 3.3.12

I remember following this guide once.

And I realized, even after doing “sudo pacman -S libinput” I can still use three finger drag. I guess it doesn’t install the main libinput alltogether.

Can you try uninstalling tlp as suggested here:

Removed TLP, then updated system.
Problem persists, it didn’t solve anything.

Quite exhausted from using Timeshift constantly…

I had to re-install libinput to fix this, see my post on forum news for latest stable update

I also reinstalled libinput after the update.
No solution.

In my case a downgrade of libwacom helped as a workaround. The current version 2.0.0 should be replaced by version 1.12. Check on your computer if this version is still available
ls -lh /var/cache/pacman/pkg/libwacom*
If yes, the command for downgrading the package is i.e.
sudo pacman -U /var/cache/pacman/pkg/libwacom-1.12-1-x86_64.pkg.tar.zst
Reboot and keep fingers crossed

I had the same problem today after this Manjaro Gnome stable update. At first I thought the total system freezing and black screen was caused by a hardware problem in SSD and I ordered a new SSD for new installation. Afterv that:

1.) I tried re-installing to the same existing SSD, but now WITHOUT UPDATING after re-installation (as I normally do), and Manjaro worked OK.

2.) After reading this thread and reply of @ochealaaf I tried downloading the stable update package to the working Manjaro Gnome, but now WITHOUT updating package of libwacom 1.12-1 → 2.0.0-2. The result: After reboot my system was frozen again the same way as earlier after update.

3.) At the end I re-installed Manjaro again and try to refrain from updating it any more until official reply and solution comes to this problem and then I can go ahead with Manjaro Gnome stable update.

I wasn’t able to solve my problem.
So I reinstalled Manjaro, not having this problem anymore.

Today I installed Manjaro 21.2.3 Gnome Stable on brand new SSD. Result: All looks OK now, also with after-installatio-updates. :grinning: