SDDM-kcm on Plasma6 not changing session type

I’m on testing branch, all applications I use they do work
only problem i face is sddm-kcm in /behavior/autologin is always deselected with option Apply ready to to be clicked
when I select the autologin (plasmax11) the Apply button is not more to be clicked
but after a reboot the situation is the same. if I select Wayland no effect
seem that I can switch to Wayland only from the login screen when I log out but the sddm-kcm shows again X11 as only option…
the start screen and the wake up screen from suspend are bigger than the screen when i log out in X11 while when I was in Plasma5 all where the same size as wake up from suspend

Autologin settings for SSD not read from kde_settings.conf correctly
It seems to be a bug in Plasma6.0.4
I don’t know the cause, but the settings are being changed when the screen is displayed.
So please press the “Reset” button, then make your changes and save them.

there is a bug yes, anyway even doing that after the reboot the autologin box is again unchecked, if you check it x11 (or wayland if I’m on wayland) the apply button is grayed out.
the autologin box does not maintain the check in both cases after the reboot or after logout and login again in the same session

It’s exactly as you say.
However, if you press “Reset” you can see the correct current settings.

not only that, it does not let me change the background in to the dark wallpaper, it will apply the dark wallpaper only in wake up from suspend

SDDM-kcm wallpaper does not seem to be overwritten and saved if the same file name is selected.
For the wallpaper when returning from suspend, please set it in “Screen locking”.

That’s about all I can help you with.

ok, thanks, got it