SDDM is not respecting resolution

When I edit the display resolution, the SDDM is not respecting it and still very small.
I tried (SDDM apply plasma settings), but it didn’t work.
I also tried (Enable HiDPI), but nothing happened.

Furthermore, I actually had the same issue when I was using vanilla arch and I fixed it, but I don’t remember the solution.

This is my system
I am using Nvidia card with 470xx driver.

Thanks in advance.

I note that the archwiki page mentions…

Note: Since sddm version 0.20.0, HiDPI support is enabled by default, and the following step is not necessary.

Do you use Plasma Wayland or Plasma X11?

When using a Wayland compositor at least, there are some additional notes in that page that may be of value.

Create a sddm configuration drop-in file /etc/sddm.conf.d/enable-hidpi.conf



Thank you so much for all your help.
I found this fix that worked perfect for me.
I can’t add a link in the reply, so the fix is navigating to


and adding this line

xrandr --output “device” --mode “mode” --rate "rate”

after changing the device and rate from xrandr in terminal.

Which will get overwritten on updates to sddm.

Instead of using the distribution file - you should create your own as described in man ssdm.conf

Path of script to execute when starting the display server. The script will be executed as root when General.DisplayServer is “x11”, otherwise as sddm user. Default value is “/usr/share/sddm/scripts/Xsetup”.

The configuration is similar for Wayland

Place a dropin file in /etc/sddm.conf.d with your script

 $ cat /etc/sddm.conf.d/00-display-command.conf
DisplayCommand=xrandr --output “device” --mode “mode” --rate "rate”

DisplayCommand=xrandr --output “device” --mode “mode” --rate "rate”

Or you could create an override using /etc/sddm/scripts/Xsetup

sudo mkdir -p /etc/sddm/scripts

Then create the override script

echo xrandr --output “device” --mode “mode” --rate "rate” | sudo tee /etc/sddm/scripts/Xsetup

Thank you so much for your reply.
I tried both of the methods, but nothing works fine.

Is there anything I can do for it??

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.