Sddm freezing when logging in

With one specific user when I log in, my pc freezes. I can log into the root user and another user I made for testing, and using ctrl alt f7, I can log in from a terminal, which is why I am sure it is to do with sddm. What I have found online (such as deleting ~/.Xauthority) hasn’t worked.

My original plan was to make a new user and transfer my data from my home directory to it, but that turned out quite buggy probably due to copying certain system files related to a specific user.

Anyone know what I can do? (if you need any diagnostic data, just ask)

Running manjaro 5.16.2-1, latest updates on everything, proprietary nvidia drivers. (I am making a backup of my home folder to a backup drive at the moment)

There currently are problems with sddm due to an upstream bug ─ which unfortunately Manjaro cannot do anything about ─ but in your case, the problem may be exacerbated by the fact that you’re using Nvidia drivers.

Nvidia is a moving target on GNU/Linux due to…

  1. the fact that they refuse to open up their driver code; and
  2. the fact that they regularly drop support for older graphics card models.

Your best bet is to wait for the KDE developers upstream to fix the bug. :man_shrugging:

Yea, nvidia drivers are bad. It isn’t just that they are proprietary (I have no issue with proprietary software), it is just that the Linux drivers are so obviously pushed to the side compared to Windows drivers.

The kde bug, I guess I will just have to wait it out. If I am smart about it I can probably migrate to a new user, at least in the meantime or permanently.

I don’t think that’ll make a difference. The fact that it didn’t happen with the other logins is simply due to the randomness of the bug. There are times when I’m running into that bug too over here, but most of the times I don’t.

It really is unpredictable, and from the technical point of view, it cannot have anything to do with your user account, because sddm only forwards your login credentials to logind, and that’s what handles the actual authentication.

Oh, OK. At least I still have my windows partition to use while waiting for an update or something, or just use a different user with a backup in case it happens again

I have found that waiting a while and wiggling the mouse a bit does help.

Your mileage may vary. :man_shrugging:

Waiting around might help… I feel like an idiot for not just leaving it there for like a few minutes. I just saw that it froze and didn’t realise that I could wait to see if it was just doing a weird thing where it takes a while to load. Just trying it now to see if it works

Tried leaving it and half an hour later, nothing