Sddm: Failed to read display number from pipe (desktop doesn't start on it's own anymore)

Since yesterday my laptop I’ve just reinstalled manjaro on a week ago doesn’t start the desktop on it’s own anymore… I can login through a tty and start the desktop by running startplasma-wayland (I prefer wayland session to x11)

looking at my journalctl output I found this:

sddm[857]: Initializing...
sddm[857]: Starting...
sddm[857]: Logind interface found
sddm[857]: Adding new display...
sddm[857]: Loaded empty theme configuration
sddm[857]: Xauthority path: "/run/sddm/xauth_fhHYdM"
sddm[857]: Using VT 2
sddm[857]: Display server starting...
sddm[857]: Writing cookie to "/run/sddm/xauth_fhHYdM"
sddm[857]: Running: /usr/bin/X -nolisten tcp -background none -seat seat0 vt2 -auth /run/sddm/xauth_fhHYdM -noreset -displayfd 16
sddm[857]: Failed to read display number from pipe
sddm[857]: Display server stopping...
sddm[857]: Attempt 1 starting the Display server on vt 2 failed
systemd[1]: systemd-rfkill.service: Deactivated successfully.
sddm[857]: Display server starting...
sddm[857]: Writing cookie to "/run/sddm/xauth_fhHYdM"
sddm[857]: Running: /usr/bin/X -nolisten tcp -background none -seat seat0 vt2 -auth /run/sddm/xauth_fhHYdM -noreset -displayfd 16
sddm[857]: Failed to read display number from pipe
sddm[857]: Display server stopping...
sddm[857]: Attempt 2 starting the Display server on vt 2 failed
ModemManager[793]: <msg> [base-manager] couldn't check support for device '/sys/devices/pci0000:00/0000:00:14.3': not supported by any plugin
wpa_supplicant[820]: wlp0s20f3: CTRL-EVENT-REGDOM-CHANGE init=DRIVER type=COUNTRY alpha2=AT
NetworkManager[740]: <info>  [1718254613.5109] manager: startup complete
sddm[857]: Display server starting...
sddm[857]: Writing cookie to "/run/sddm/xauth_fhHYdM"
sddm[857]: Running: /usr/bin/X -nolisten tcp -background none -seat seat0 vt2 -auth /run/sddm/xauth_fhHYdM -noreset -displayfd 16
sddm[857]: Failed to read display number from pipe
sddm[857]: Display server stopping...
sddm[857]: Attempt 3 starting the Display server on vt 2 failed
sddm[857]: Could not start Display server on vt 2
systemd[1]: NetworkManager-dispatcher.service: Deactivated successfully.

help please…

maybe this information helps too:

$ inxi -G
Graphics:
  Device-1: Intel Raptor Lake-P [Iris Xe Graphics] driver: i915 v: kernel
  Device-2: Chicony ACER QHD User Facing driver: hid-generic,usbhid,uvcvideo
    type: USB
  Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 24.1.0
    compositor: kwin_wayland driver: X: loaded: vesa gpu: i915
    resolution: 2133x1333
  API: EGL v: 1.5 drivers: iris,swrast
    platforms: wayland,x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.9-manjaro1.1
    renderer: Mesa Intel Graphics (RPL-P)
  API: Vulkan v: 1.3.279 drivers: intel surfaces: xcb,xlib,wayland

okey, I wanted to switch sddm to wayland anyway so I did that and now it works again.

(did it by following the instructions found here: Make SDDM itself run on Wayland - Support / KDE Plasma - Manjaro Linux Forum which I guess have been taken from SDDM - ArchWiki)

create file /etc/sddm.conf.d/10-wayland.conf
with content:

[General]
DisplayServer=wayland
GreeterEnvironment=QT_WAYLAND_SHELL_INTEGRATION=layer-shell

[Wayland]
CompositorCommand=

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.