Sd-umount: Failed to unmount /oldroot on Shutdown or Reboot

i’m receiving this error on reboot or shutdown.

Is this a danger for my SSD?
Does someone know how to fix this?
Tnx in advance!


Hi @leestudyante,

Thank you for reporting this. I can confirm that I’m getting this as well.
The only reason I’ve not asked about it yet, is because there doesn’t seem to be any operational problems, so it slips my mind until next shutdown. So thanks for reporting.

! bump !

1 Like

Add shutdown to HOOKS line in /etc/mkinitcpio.conf and then run from terminal
sudo mkinitcpio -P
Make a test and report back if it fixes the issue.

tnx for the answer.
Unfortunately it didn’t help.
I still get the same errors.

Additional Info:
I’m running dual boot with Windows 10.
And my Manjaro Linux is installed in a separate SSD.

Assuming Grub is the bootloader, isn’t sudo update-grub needed?

@Chhkuot yeah, Grub is the bootloader
just did sudo update-grub no change

I’ve decided to install Ubuntu.
It’s just that i have too many problems with Manjaro at the moment
and I needed a working computer for University.
Thx for the replies!
Have a good one!!

@leestudyante Take care!

For other folks reading this:

TL;DR It is said to be a systemd issue,

1 Like

these errors doesn’t occur in Ubuntu

OP, I’ve been having the same problems today as well. I run Manjaro on my SSD, and Windows 10 on my other drive.

Shutting down my system from Manjaro gives me the logs “Failed to unmount /oldroot”, “Failed to unmount /oldroot/sys”, and “Failed to finalize file systems, ignoring.” And then, when I reboot, it either stalls on a blank, black screen, or it send me straight into Manjaro without showing me BIOS prompts or loading GRUB for boot OS selection.

@leestudyante, just curious, is your SSD perchance the Samsung NVME EVO Plus 970?

1 Like

I also have this error with my external usb drive :frowning:

Same errors for me on a fresh Manjaro install on new NVMe drive. I do have one more NVMe containing Windows 10 and old Manjaro installation (yet). Both are available in GRUB. Two more SSD with NTFS filesystem and one USB HDD with ext4 (Timeshift backup) and NTFS partitions. All drives are automatically mounted by built in KDE utility.

Would like to solve those errors.

1 Like

I also have the issue (and want to see what solutions are proposed)

Same issue for me - Manjaro KDE and Win 10 on one NVMe drive, available via GRUB.
Sometimes the shutdown procedure can take 1-2 minutes.

Also have this problem with a new Lenovo V17-IIL Laptop (no nvidia hardware). Running the newest Manjaro Gnome Iso 21.0.2

Slice=-.slice was already added to the bottom of this file (as root) /usr/lib/systemd/user/gnome-session-restart-dbus.service.
So this is no fix!

I also have this. And I’ve researched quite a bit on it.

Apparently, it’s purely cosmetic and nothing to worry about. (I can’t remember where I read that, so can’t provide you guys with the link.)

The Problem is that it’s really annoying having to wait ~ 2-3 minutes for the system to reboot or to shutdown. So although it doesnt break anything critical its still an annoying error.

That’s very true. Luckily, for me at least, I very rarely rest5art my computer, when I’m in front of it. Only for updates. So I didn’t notice it for that.

I only noticed it with shutdown. And I don’t hang around to wait for my PC to shutdown. I click shutdown and leave it be. So it doesn’t really other me.

But for what it’'s worth, it’s not a Manjaro-bug. It’s systemd I think. If you search Google you’ll find the problem isn’t localized to Manjaro, but appears in, at least, 2 other distributions as well.