Sd card refused to be read by Manjaro

Today i tried to insert my sd card reader in my laptop. Unfortunately, it refused to read. My sd card works on my phone. Any possibly way i can fix this problem? Using the recent manjaro xfce stable update with linux kernel 5.7.

Hello TurkeyBobo,
you could try:

  • replugging the device, see if the problem persists
  • check that the usb/sd port works
  • type lsblk -f in a terminal to see, what filesystem the sd card uses.

for me this command shows for my connected partitions:
As you can see, the Seagate Drive for example uses the ntfs filesystem, for which I had to install a package. If you could post, this might be the issue.

[julius@Pinebook ~]$ lsblk -f
NAME FSTYPE FSVER LABEL UUID FSAVAIL FSUSE% MOUNTPOINT
sda
├─sda1
└─sda2 ntfs Seagate Expansion Drive DC76B1F276B1CD90 3.6T 1% /run/media/julius/Seagate Expansion Drive
mmcblk2
├─mmcblk2p1 vfat FAT16 BOOT_MNJRO 2AFC-FAC8 152.6M 28% /boot
└─mmcblk2p2 ext4 1.0 ROOT_MNJRO 1cde3a59-5318-4d1e-876e-4c0521ffe02f 35.3G 34% /
mmcblk2boot0
mmcblk2boot1
zram0

Please post, what it uses, so we can see whether this is the issue.

Best Regards, Julius

1 Like

I tried what you told me and it still doesn’t show up anything, at all. Could be a driver related issue?

So doesn’t show up at all with this command?

Nope. It might be a problem from XFCE itself. Regardless, i’m still open for solutions!

Please read this:


and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…

:innocent:

P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which CPU/GPU you have, …

1 Like

do you have another sd card? If so, could you try looking whether that one works?
Just to check that the sd card port on the computer isn’t dead.

Quick.update : Apparently it works if i leave my sd card reader plugged in while booting up my pc. Clearly a bug from XFCE or something else. Thanks a lot for the help!

Ah! It’s an external SD card reader!!!

(I’m betting everyone else in this thread was assuming an internal one!)

:rofl:

1 Like

My mistake for not mentioning it properly :))

1 Like

I dont think that this is a bug in XFCE. It works fine for me with external SD card reader. What are your file manager settings regarding “removable devices”? Please have look at the thunar settings.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.