SD Card not detected unless booted with card in or lspci command ran

I recently installed Manjaro and I had to access one of my 64GB SD cards and yesterday everything was working just fine, but today I had some problems with it. When I plugged in nothing happens, so I tried again and again. Then I restarted my computer and the behavior was the same. But then I tried rebooting with SD card plugged in and then it worked. And it became really annoying because I have quite a few of them and I was about to backup them.
There is also similar topic, but I am already on the newest LTS kernel (5.15.59-1) and it was first and only installed kernel form the start of this Manjaro installation.

As I ran lspci SD card has mounted, I was surprised but I wanted to make sure it was fixed. It was not. When I reconnected SD card it wasn’t detected but as soon as I ran lspci it was detected again. So it seems that Manjaro doesn’t scan/detect it automatically at least for me.

Here is the output of lspci and dmesg commands.

Thanks in advice!

possible a ntfs-card and no ntfs-support installed ?
please boot with the sd-card detected and post the output of

lsblk -f

with inserted card