Scribus Open file dialogue doesn't show network / online account drives

I noticed that within the Open dialogue function of some programs (in my case Scribus), all the network drives are not shown.
As I am using a Nextcloud server to share files between several computers I was wondering if this is a Scribus issue, or if there could be a workaround.
Currently I have the Nextcloud drive mounted with the built in online account tool of manjaro.
I also tried to use the network mount function of the file browser, but both of them are not shown in the Scribus Open file dialouge.

I also tried to mount the Nextcloud drive via fstab, but still struggle with authentication and automaounting.

Therefore I was wondering if somebody has an alternative idea how to open files on network drives in Scribus.


From what I have learned about mounting NAS drives , fstab is not the way to do it.
The problem with it comes from timing of Wifi connection not running when the fstab tries to connect and the network is not available. Look up systemd automount. That works for me but I have a problem on reboot that it has a delay I am still trying to figure out but it works.
I don’t have Scribus so I don’t know know if that is an issue.

Mount your share in a designated folder.

Then you can use this as any other storage path.

Nextcloud can be mounted using webdav - and can be easily done using a couple of systemd units.