Screenshots not working

The fix is already done, apparently. When Manjaro upgrades their packages, everything should be good. You should still be able to use a screenshot tool without using the keyboard shortcut no?

Sure! I am just too used to use the Print Screen key!

You can map a different screenshot app to the printscreen button, that’s what I did

I worked out a fix, as follows.

1. Add any of the following custom shortcuts.

Name: screenshot
Command: bash -c "gnome-screenshot -f ~/Pictures/screenshots/\"Screenshot from $(date '+%Y-%m-%d@%H:%M:%S')\".png"

Name: screenshot area
Command: bash -c "gnome-screenshot -af ~/Pictures/screenshots/\"Screenshot from $(date '+%Y-%m-%d@%H:%M:%S')\".png"

Alternatively, if you have scrot installed (which is great software!), you can set up the following custom shortcuts instead.

Name: screenshot
Command: bash -c "scrot ~/Pictures/screenshots/\"Screenshot from %Y-%m-%d@%H:%M:%S\".png"

Name: screenshot area
Command: bash -c "scrot -s ~/Pictures/screenshots/\"Screenshot from %Y-%m-%d@%H:%M:%S\".png"

2. Set their keyboard bindings as you like.

For example, to the Print Screen key.

3. Set the screenshots location.
The above works if you have a folder named screenshots in your Pictures home folder.
You can tweak the folder and filename pattern in the commands above, but be careful with spaces and other special characters.

4. Further customization if needed.

  • Useful options can be found by typing man gnome-screenshot or man scrot in a terminal.

Thanks! But… really did an update broke the PrintScreen key and users are expected to fix it by hand?

And, also, how can see the CURRENT screenshot key command? I can add new commands, but I don’t know how to see or edit the commands that are currently executing.

No, I think the update just broke the default “Take a screenshot” command. Indeed, even if you bind it to a different key than PrintScreen, the “Not allowed” icon still appears as on your photo.

On the other hand, the PrintScreen key works fine for me with the custom shortcuts I proposed above.

Or to wait for the next update, I guess.

The default Cinnamon screenshot command seems hard-coded in C language instead of using a simple terminal command. The relevant C code seems here.

Thanks, your temporary solution works very nicely, but I cant bind ctrl+shift or anything, that just takes screenshots automatically.

Did you open Cinnamon keyboard settings? I mean, the window in the picture below. The steps I previously described are supposed to be done in this window.

Yes, I did bind a print key to a custom shortcut command mentioned by you and it works. Now if I try to bind “ctrl+shift” or “ctrl+enter” to media pause/play, it instead of pausing media takes screenshots of screen.

Indeed, I had the same bug this morning.

Then I installed the new update, rebooted, and the issue seems resolved: Cinnamon shortcut settings seem to work fine now.

The custom shortcuts I proposed above can be deleted.

Yep working Nicely, relief…