Screenshot Tool Extension - Error Since Gnome 40.x

Hello Everyone,

I am a big fan of the Gnome Extension, “Screenshot Tool.” Direct link below:

The Problem:
However, since upgrading to Gnome 40, the extension has been broken for me. The extension starts and looks normal, however when trying to take a screenshot it errors out.

Is anyone else experiencing the same issue? Does anyone have a workaround to get things working again with the screenshot-tool extension under Gnome 40 + Wayland?

Thanks in advance to everyone for your time and help. It is greatly appreciated!

Uninstall the current one and try installing manually via github:

git clone
cd gnome-shell-screenshot
make update_dependencies
make install

Thanks, after I do the make install step, what’s next? Do I need to copy the unzipped files to a specific location?

Sorry for newb question!

It should already be installed after the “make install” step. Are you able to launch it now?

I don’t see anything in my Gnome Extensions Application with it listed (installed). Let me do a quick restart and check.

It installed, but it looks like I am getting the same error as before. I took a screenshot (using a different Screenshot utility) to capture the error I am seeing:


Thanks for your help so far, I really appreciate it!


It uses the gnome-screenshot cli tool as the default backend.

Install gnome-screenshot and try again:

sudo pacman -S gnome-screenshot

Was this the same error you got before? Next time rather than telling that there’s a error also share that what’s the error. Also refrain from sharing screenshots for text based stuff.

This fixed the issue (installing gnome-screenshot)! Thanks for helping me out @ishaan2479, I super appreciate it.

I suggest you uninstall the manually installed extension and install again the one from gnome-extensions website.

cd ~/gnome-shell-screenshot
sudo make uninstall

and then install as usual so that you can keep em in one place :+1:

Are you sure? :wink: