Screenshot doesn't work properly in gnome

Hello everyone, since the last update I’m noticing a problem with screenshot, when I press PrintScreen I can’t see the area I’m trying to capture, the option of “screen” and “windows” seems to work normally, but when selecting an area I can’t see the difference between the gray part and the “visible” part that will be captured, it’s a little hard to explain so i tried to record a video. screenshot-problem, system is up-to-date, I didn’t changed the GPU driver or something like this, just ran the command sudo pacman -Syu about two or three days ago, tried to reinstall the screenshot tool but I didn’t find any package related to it when I try to search for “screenshot” or “printscreen”, is there anything else I can do?

inxi -Fxz                                                        ✔ 
  Kernel: 5.18.10-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    Desktop: GNOME v: 42.3.1 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: PRIME B450M-GAMING/BR v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 2006
    date: 11/13/2019
  Info: 6-core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+
    rev: 2 cache: L1: 576 KiB L2: 3 MiB L3: 16 MiB
  Speed (MHz): avg: 2250 high: 3892 min/max: 1550/3400 boost: enabled
    cores: 1: 3892 2: 1566 3: 1479 4: 3169 5: 2600 6: 2192 7: 2777 8: 1608
    9: 1542 10: 2650 11: 1413 12: 2119 bogomips: 81471
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: XFX Pine driver: amdgpu v: kernel arch: GCN 4 bus-ID: 08:00.0
  Device-2: A4Tech REDRAGON Live Camera type: USB driver: uvcvideo
    bus-ID: 3-1:2
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2 driver: X:
    loaded: amdgpu unloaded: modesetting,radeon gpu: amdgpu
    resolution: 1920x1080~70Hz
  OpenGL: renderer: AMD Radeon RX 570 Series (polaris10 LLVM 14.0.6 DRM
    3.46 5.18.10-1-MANJARO)
    v: 4.6 Mesa 22.1.3 direct render: Yes
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: XFX Pine driver: snd_hda_intel bus-ID: 3-1:2 v: kernel
    bus-ID: 08:00.1
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel bus-ID: 0a:00.3
  Device-3: A4Tech REDRAGON Live Camera type: USB driver: uvcvideo
  Device-4: FIFINE Microphones K670 Microphone type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-4:4
  Sound Server-1: ALSA v: k5.18.10-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: no
  Sound Server-4: PipeWire v: 0.3.54 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel port: f000
    bus-ID: 07:00.0
  IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 447.13 GiB used: 317.44 GiB (71.0%)
  ID-1: /dev/sda vendor: Kingston model: SA400S37480G size: 447.13 GiB
  ID-1: / size: 58.76 GiB used: 33.76 GiB (57.5%) fs: ext4 dev: /dev/sda2
  ID-2: /boot/efi size: 196.9 MiB used: 274 KiB (0.1%) fs: vfat
    dev: /dev/sda1
  ID-3: /home size: 379.8 GiB used: 283.68 GiB (74.7%) fs: ext4
    dev: /dev/sda3
  ID-1: swap-1 type: file size: 4 GiB used: 55.5 MiB (1.4%) file: /swapfile1
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 50.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1094
  Processes: 359 Uptime: 10h 7m Memory: 15.55 GiB used: 7.86 GiB (50.5%)
  Init: systemd Compilers: gcc: 12.1.0 clang: 14.0.6 Packages: 1409
  Shell: Zsh v: 5.9 inxi: 3.3.19

It appears to be an issue with your custom GNOME Shell theme. Switch it to default and see if you can reproduce it. You may need to logout / login to test.

1 Like

Yeah, changing the gnome-shell theme to whitesur solved the problem, thanks for your answer mate.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.