Screen/Video Issues on iMac 2008, XFCE


I have an old iMac laying around, i changed its HDD for another one, because the previous one was faulty, After that, i wanted to try linux and found manjaro, I downloaded the ISO, created a bootable USB and got to the GRUB launcher.

After that, i tried running with free drivers, only to find my screen teared apart with black/white stripes. (Apparently I can’t embed pictures)

What do I do? It seems that I can open a terminal after some time, but what should I do? I read some forum posts but really nothing similar to what I’m experiencing, please help!


Check iMac Aluminum - ArchWiki if you left out some details.

Thanks for your reply!

I have read the guide but found nothing related to my graphics’ issue, perhaps installing rEFIT might help? I might be wrong, but I don’t think the issue is there :confused:

The blog post at the end of the wiki (from which it was created) is really old and possibly outdated (?) since it uses Catalyst drivers, which, as far as I’m aware, are now deprecated.

I don’t think there’s a solution to my problem there, but will keep an eye on it. Anything else I might provide you in order to help?


At the bottom of it:

Try different kernels then …

Could you elaborate on how to do that? the different kernels?

Install a newer kernel like 5.13 from terminal or from MHWD
sudo mhwd-kernel -i linux513
If you kept Manjaro grub then you reboot from it.

I installed different kernels, however, when i reboot, they are no longer there. I’m running from a bootable USB. How can I change kernels this way?

Edit: I’m already running linux 5.13

After tinkering for a while, I noticed that something is stuck on Light Display Manager.

Usually that should reflect an installed system, but not always … Personally i do not rely much in live sessions to determin or investigate things.

Well, I’m not able to install it since… I don’t see anything.

Finally able to upload a picture!

So, how would you go about resolving this issue then? I’m kinda stuck :frowning:

If Architect was available, you could try to install trough it.
I only know about this that could help with the display issue

Isn’t it available?

Thanks for the help, do you know how to access xorg.conf? They mention the file but not where is located.

I’m also thinking, won’t that file configuration reset itself once I have to reboot the computer for it to take effect?


You can’t do changes in the live environment that will survive a reboot. Is not possible. You have to install the system and then do the changes.

While in grub boot menu of install media, press e to edit the entry, replace quie splash with nomodeset
then press F10 to save and continue booting and see if you can live boot and install that way, after that, do the same on the installed system and then add the xorg.conf.

It won’t display properly, even with nomodeset. :frowning: I’m running out of ideas to try.

Have you tried to boot a different ISO, different DE, or even try a WM ISO like i3wm … and start from there ?

Could you elaborate? Didn’t get you.

You tried to boot XFCE ISO and is giving you that screen artifacts.
Have you tried KDE Plasma ISO, or Gnome ISO … ? All 3 DEs have different display manager and compositor, and maybe one will not fail that badly on your iMac.

I have tried Linux Mint, I had it working for a while with the same screen issues, I got it working by setting a GRUB param. However it was not replicable, and really unstable. So i tried installing Mint XFCE to no avail, and now I’m trying Manjaro because I heard the documentation was better. Sadly no luck so far. I will try Plasma and Gnome, but I’m getting frustrated tbh.