Screen turns off while on a Telegram Voice or Video call

I am using the latest manjaro stable release of KDE Plasma…
I have noticed that when talking over Video call over Telegram (installed via the Manjaro Software manager), after not having used the mouse for a while the display dims and turns off… And if i leave it like that, my laptop goes to sleep mode and disconnects the wifi as well, disconnecting the call I am on.

This has happened for both voice and video calls.

Also after the system goes to sleep, waking up the system using space bar makes me have to press backspace before typing the password. Waking from sleep is much more seamless on Windows. It’s a small thing, but I think these things matter.
Manjaro bootloader remembering which OS i had used last time is another such small but amazing feature.

Telegram has no power management integration with KDE Plasma. If you set to turn off the display after a certain amount of time, then that will happen. To avoid that, either you turn off that option, or create a separate Activity for video call, and set it like this

image

Depending on how long you set the timer for sleep, you can also enable the option, bellow the one i mentioned, in your Activity.

1 Like

Thanks for the response… I have changed the suspend timer in the “Activity Settings”
But it would be better if the Telegram Desktop app and other Linux Apps could have power management integration with KDE Plasma, so that one would not have to choose between battery saving and convenience.
Is that possible in the near future?

It depends on Telegram and KDE Plasma developers if there will be such integration for power management.

You can also always click your power management widget:
image

Or … since I couldnt rely on my partner to do that either with some application, I wrote a script to inhibit sleep; launch; uninhibit sleep, and replaced the launcher with that … new problem is they dont reliably exit the application either … so now the system is just ‘awake’ for hours on end… :woman_shrugging: