Screen tearing on Intel card Lenovo think pad

I installed Manjaro KDE and noticed a screen tearing while scrolling or watching youtube videos on full screen. had the same Problem with Ubuntu 20 and never been solved there even with tearfree enabled.

still didn’t try anything here on manjaru aliitle bit afraid of missing the system so I thought I should ask here first. oh I switched to the Video-modesetting driver from the Video-linux and nothing changed.

any suggestions ?

system info :

System:
  Kernel: 5.7.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  Desktop: KDE Plasma 5.19.5 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: LENOVO product: 20RW v: Lenovo ThinkBook 15-IML 
  serial: <filter> 
  Mobo: LENOVO model: LVA/LVAB v: NO DPK serial: <filter> UEFI: LENOVO 
  v: CJCN29WW date: 06/19/2020 
Battery:
  ID-1: BAT1 charge: 44.9 Wh condition: 44.9/45.0 Wh (100%) 
  model: Celxpert L19C3PF1 status: Full 
CPU:
  Topology: Quad Core model: Intel Core i5-10210U bits: 64 type: MT MCP 
  arch: Kaby Lake rev: C L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 33615 
  Speed: 800 MHz min/max: 400/4200 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
Graphics:
  Device-1: Intel UHD Graphics vendor: Lenovo driver: i915 v: kernel 
  bus ID: 00:02.0 
  Device-2: Acer SunplusIT Integrated Camera type: USB driver: uvcvideo 
  bus ID: 1-6:4 
  Display: x11 server: X.Org 1.20.8 driver: modesetting 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 20.1.7 
  direct render: Yes 
Audio:
  Device-1: Intel vendor: Lenovo driver: snd_hda_intel v: kernel 
  bus ID: 00:1f.3 
  Sound Server: ALSA v: k5.7.19-2-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8168 v: 8.048.03-NAPI port: 3000 
  bus ID: 01:00.0 
  IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Device-2: Realtek vendor: Lenovo driver: N/A port: 2000 
  bus ID: 02:00.0 
Drives:
  Local Storage: total: 931.51 GiB used: 8.49 GiB (0.9%) 
  ID-1: /dev/sda vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB 
Partition:
  ID-1: / size: 908.32 GiB used: 8.49 GiB (0.9%) fs: ext4 dev: /dev/sda2 
Swap:
  ID-1: swap-1 type: partition size: 7.39 GiB used: 0 KiB (0.0%) 
  dev: /dev/sda3 
Sensors:
  System Temperatures: cpu: 43.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 210 Uptime: 51m Memory: 3.36 GiB used: 1.51 GiB (44.8%) 
  Init: systemd Compilers: gcc: 10.2.0 Packages: 1175 Shell: Bash 
  v: 5.0.18 inxi: 3.1.05

There have been a few reports of this. On mine, VSync (screen tearing) issues are very evident with those things you describe when the compositor is NOT running; seems hardly noticeable with these settings:

1 Like

If that helped, please mark a solution like this:
Solution
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

:innocent:

1 Like

I had a similar problem with my Intel iGPU, I couldn’t watch 1080p youtube video’s without it stuttering like crazy. I tried different solutions, don’t really know which one worked best but all togheter they solved my problem with youtube xD:
1- make shure that your browser is using hardware acceleration, there are a lot of browser specific tutorials on this forum or online in general so it should be easy. Mine wasn’t but enabling it didn’t make a significant difference so I had to try something else, altough it solved the tearing and stuttering problems for someone.
2- install libva-intel-driver pack from pamac
If this doesn’t solve your problem you could try libva-intel-driver-g45-h264 and install the h264ify plugin on chrome/firefox/whatever you are using. This combination worked for someone but it made very little difference for me so your mileage may vary
3- try OpenGL 3.1 as rendering backend if you are using OpenGL 2.0
4- install xf86-video-intel pack from pamac. I don’t remember what this does or where I read it could make a difference, but in combination with point 5 solved my problem
5- make shure your display manager in system settings is set to “video-linux”. This in combination with point 3 made my life a lot better and now youtube videos are smooth even at 1080p

Look, I’m no power or advanced user, those are just the things that I tried to solve my problem over a span of three weeks, I was very frustrated cause no solution that I could find worked for me, so be careful if you want to try it out. You should always backup your system as they say!
Let me know if this was helpful, have a great day!

[EDIT] libva-intel-driver-g45-h264 in combination with the plugin did actually help with the stuttering and tearing issue that I had but every other application, like games, that relied heavly on GPU was worse than before.

1 Like

still looking into it

1 Like

thanks a lot, I will try them and give a feedback .