Screen Tearing on GNOME Hybrid Gaphics

Hey all, I have some seriously bad screen tearing issues on Manjaro Gnome.
Using the video-hybrid-intel-nvidia-prime driver from mhwd. Using the latest LTS kernel and using.
Other things, my GPU is a NVIDIA GeForce RTX 2070 SUPER Mobile and my CPU is Intel i7-10750H (12) @ 5.000GHz.

How can I fix the screen tearing issue? Only things I found on Google or on the Arch Wiki seem to be related to the ordinary nvidia-4xx drivers and which I don’t have the options on installing besides, i like having the hybrid graphics option. I’ve tried those options but they have caused issues like no booting.Anyone have any ideas? I’ve considered switching to Wayland but I rely heavily on Wine/Proton for gaming so currently that isn’t an option.


Basically adding the tearfree option for Intel, as it is Intel that renders your video (and you offload on-demand on Nvidia card some work for gaming or whatever, but it still is Intel which displays video from my understanding, with the hybrid driver).

I’ve tried this option but afterwards I couldn’t boot my system anymore, it would just freeze before loading GDM the user login screen.

I don’t own a laptop and can’t access hybrid laptop currently to check, but it shouldn’t forbid you to boot if you add this option to your xorg config file.

Option "TearFree" "true"

Just tried this option again and still wouldn’t load GDM. I can use Crt-Alt F2 to get into a second tty session and login without a DE but that’s it.

Where/how do you add this option exactly in detail?

Following the Arch wiki guide I put it in /etc/X11/xorg.conf.d/20-intel.conf and copy the following into it.

Section "Device"
    Identifier "Intel Graphics"
    Driver "intel"
    Option "TearFree" "true"

Is there a different location I should be putting this in?

That is what I wonder, but as I told you I do not have a laptop with Prime on hand currently to check. In the folder etc/X11/ if you already have configuration files there it may be the place, but I can’t tell you which file sorry.

No worries, cheers for your input though.
I do have a 90-mhwd.conf file in /etc/X11/xorg.conf.d however it’s just filled with the following and nothing else

'## Generated by mhwd - Manjaro Hardware Detection

Going to try pasting it in here and seeing the results.

Pasting it all into 90-mhwd.conf caused the same issue.

Can you give full inxi output?

inxi -Fazy

This is the output without any X11 modifications.

  Kernel: 5.10.32-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.10-x86_64 
  root=UUID=1e76304c-c2d9-4915-b8f2-3b3bc641fa30 rw rootflags=subvol=@ quiet 
  splash apparmor=1 security=apparmor 
  resume=UUID=b996df8a-0e33-4fb9-9a8e-79145e767d3b udev.log_priority=3 
  Desktop: GNOME 3.38.4 tk: GTK 3.24.29 wm: gnome-shell dm: GDM 40.0 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: Micro-Star product: GS66 Stealth 10SFS v: REV:1.0 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: Micro-Star model: MS-16V1 v: REV:1.0 serial: <filter> 
  UEFI: American Megatrends v: E16V1IMS.106 date: 03/11/2020 
  ID-1: BAT1 charge: 48.7 Wh (77.1%) condition: 63.2/95.0 Wh (66.5%) 
  volts: 15.9 min: 15.2 model: MSI BIF0_9 type: Li-ion serial: N/A 
  status: Charging 
  Info: 6-Core model: Intel Core i7-10750H bits: 64 type: MT MCP 
  arch: Comet Lake family: 6 model-id: A5 (165) stepping: 2 microcode: E0 
  cache: L2: 12 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 62399 
  Speed: 800 MHz min/max: 800/5000 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics vendor: Micro-Star MSI driver: i915 v: kernel 
  bus-ID: 00:02.0 chip-ID: 8086:9bc4 class-ID: 0300 
  Device-2: NVIDIA TU104M [GeForce RTX 2070 SUPER Mobile / Max-Q] 
  vendor: Micro-Star MSI driver: nvidia v: 460.73.01 
  alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1e91 
  class-ID: 0300 
  Device-3: Acer HD Camera type: USB driver: uvcvideo bus-ID: 1-11:3 
  chip-ID: 5986:2127 class-ID: 0e02 serial: <filter> 
  Display: x11 server: 1.20.11 compositor: gnome-shell driver: 
  loaded: modesetting,nvidia alternate: fbdev,intel,nouveau,nv,vesa 
  resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.0.3 
  direct render: Yes 
  Device-1: Intel Comet Lake PCH cAVS vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci 
  bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0403 
  Device-2: NVIDIA TU104 HD Audio vendor: Micro-Star MSI driver: snd_hda_intel 
  v: kernel bus-ID: 01:00.1 chip-ID: 10de:10f8 class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.32-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.26 running: no 
  Device-1: Intel Comet Lake PCH CNVi WiFi vendor: Rivet Networks 
  driver: iwlwifi v: kernel port: 4000 bus-ID: 00:14.3 chip-ID: 8086:06f0 
  class-ID: 0280 
  IF: wlo1 state: up mac: <filter> 
  Device-2: Intel driver: igc v: kernel port: 3000 bus-ID: 3c:00.0 
  chip-ID: 8086:3100 class-ID: 0200 
  IF: enp60s0 state: down mac: <filter> 
  Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 1-14:4 
  chip-ID: 8087:0026 class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends 
  Local Storage: total: 953.87 GiB used: 280.22 GiB (29.4%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVLB1T0HALR-00000 
  size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 rotation: SSD serial: <filter> rev: EXA7301Q temp: 46.9 C 
  scheme: GPT 
  ID-1: / raw-size: 935.94 GiB size: 935.94 GiB (100.00%) 
  used: 280.22 GiB (29.9%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3 
  ID-2: /boot/efi raw-size: 954 MiB size: 952.1 MiB (99.80%) 
  used: 576 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  ID-3: /home raw-size: 935.94 GiB size: 935.94 GiB (100.00%) 
  used: 280.22 GiB (29.9%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 17 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p2 maj-min: 259:2 
  System Temperatures: cpu: 61.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 320 Uptime: 5m wakeups: 1 Memory: 15.46 GiB 
  used: 2.47 GiB (16.0%) Init: systemd v: 247 tool: systemctl Compilers: 
  gcc: 10.2.0 Packages: pacman: 1190 lib: 322 flatpak: 0 Shell: Zsh v: 5.8 
  running-in: gnome-terminal inxi: 3.3.04

I found a thread with exact same problem, as soon as you add configs for Intel you can not boot to desktop How to Fix Intel Screen Tearing on Xfce

The guy fixed his issue in the windows manager settings, but it was for XFCE not GNOME.

Maybe you have some options somewhere in GNOME where you could enable some kind of sync/buffer/whatever it could be.

I don’t use GNOME so I can’t really help for that.

Cheers mate, can’t find anything in the Gnome Settings GUI or Gnome Tweaks but I’ll do a bit of research online after work and see if I can find anything relating to sync/buffer settings for Gnome.

Cheers mate! :slightly_smiling_face: