Screen tearing on Firefox

CPU: Dual Core Intel Core i5-3210M (-MT MCP-)
speed/min/max: 1627/1200/3100 MHz Kernel: 5.10.23-1-MANJARO x86_64
Up: 28m Mem: 3118.2/7864.4 MiB (39.6%) Storage: 223.57 GiB (3.4% used)
Procs: 183 Shell: Bash inxi: 3.3.03

Have disabled compositor and it seems to have resolved screen tearing.

1 Like

Thank you! This fixed it—heck, made everything snappier, too! This had been driving me crazy for awhile now…I really don’t know when it began but Firefox had been displaying screen tearing for a little while and, for some reason, I’d been dealing with a complete UI freeze as soon as I’d click ‘Compositor’ (before disabling it I timed it to 1 minute 42 seconds after clicking!), now it immediately loads. The whole UI is snappier of course now. I’d tried switching between XRender, OpenGL 3.1, various vsync and [Firefox] about:config settings to no avail, I just disabled it, logged back in and it’s snappy again.

From System Information
Operating System: Manjaro Linux
KDE Plasma Version: 5.21.4
KDE Frameworks Version: 5.81.0
Qt Version: 5.15.2
Kernel Version: 5.12.1-2-MANJARO
OS Type: 64-bit
Graphics Platform: X11
Processors: 12 × Intel® Core™ i7-8700K CPU @ 3.70GHz
Memory: 62.7 GiB of RAM
Graphics Processor: AMD Radeon RX 5700 XT

There are various methods depending on the hardware, to have no tearing.

For Intel video or AMD video, you need to enable the TearFree option in the xorg configuration.
For Nvidia video you have to enable Force Full Composition Pipeline in the drivers Advanced Settings and/or xorg configuration.


Oddly enough, because [Steam] Proton was starting to take forever to launch games, I decided to re-enable the Compositor (still takes about 1 minute 40 seconds to pop up) and it appears to have resolved itself—save for the exponentially long time it takes for Compositor to pop up in System Settings.

Using xrandr --verbose I see that it’s indeed set to "Auto"

To see if there appeared to be a difference I tried xrandr --output DisplayPort-2 --set TearFree on to set it temporarily and so far it appears the same.