Screen tearing Intel

Hi sorry for my english
My screen tearing when i move window,scrolling page and when i watch video on website
I think i tried every way but nothing worked
note: this not hardware problem because on windowsOS no tearing
system info:

System:
Kernel: 5.4.72-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64
root=UUID=f086df2a-9cb3-47de-a3e3-6f7558b66356 rw quiet apparmor=1
security=apparmor resume=UUID=b34641ef-1d96-485f-bcad-a47bf30cf04f
udev.log_priority=3
Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM
Distro: Manjaro Linux
Machine:
Type: Laptop System: LENOVO product: 4384AJ9 v: ThinkPad T510
serial: Chassis: type: 10 serial:
Mobo: LENOVO model: 4384AJ9 serial: BIOS: LENOVO
v: 6MET92WW (1.52 ) date: 09/26/2012
Battery:
ID-1: BAT0 charge: 36.0 Wh condition: 36.0/38.9 Wh (93%) volts: 12.4/10.8
model: SANYO 42T4791 type: Li-ion serial: status: Full
CPU:
Topology: Dual Core model: Intel Core i5 M 520 bits: 64 type: MT MCP
arch: Nehalem family: 6 model-id: 25 (37) stepping: 5 microcode: 7
L2 cache: 3072 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19156
Speed: 1336 MHz min/max: 1199/2400 MHz boost: enabled Core speeds (MHz):
1: 1336 2: 1667 3: 1354 4: 1391
Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds
status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel Core Processor Integrated Graphics vendor: Lenovo
driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0046
Device-2: Microdia HP Integrated Webcam type: USB driver: uvcvideo
bus ID: 1-1.6:5 chip ID: 0c45:6321
Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: intel
display ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
s-diag: 414mm (16.3")
Monitor-1: LVDS1 res: 1366x768 hz: 60 dpi: 99 size: 350x190mm (13.8x7.5")
diag: 398mm (15.7")
OpenGL: renderer: Mesa DRI Intel HD Graphics (ILK) v: 2.1 Mesa 20.1.8
direct render: Yes
Audio:
Device-1: Intel 5 Series/3400 Series High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:3b56
Sound Server: ALSA v: k5.4.72-1-MANJARO
Network:
Device-1: Intel 82577LM Gigabit Network vendor: Lenovo driver: e1000e
v: 3.2.6-k port: 1820 bus ID: 00:19.0 chip ID: 8086:10ea
IF: enp0s25 state: down mac:
Device-2: Intel Centrino Advanced-N 6200 driver: iwlwifi v: kernel
port: 1880 bus ID: 03:00.0 chip ID: 8086:4239
IF: wlp3s0 state: up mac:
Drives:
Local Storage: total: 465.76 GiB used: 20.60 GiB (4.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda vendor: Toshiba model: MQ01ABD050 size: 465.76 GiB
block size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
rotation: 5400 rpm serial: rev: 5A scheme: GPT
Partition:
ID-1: / raw size: 180.48 GiB size: 176.64 GiB (97.88%)
used: 20.60 GiB (11.7%) fs: ext4 dev: /dev/sda2
Swap:
Kernel: swappiness: 60 (default) cache pressure: 100 (default)
ID-1: swap-1 type: partition size: 3.01 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sda1
Sensors:
System Temperatures: cpu: 41.0 C mobo: 0.0 C
Fan Speeds (RPM): cpu: 2598
Info:
Processes: 191 Uptime: 29m Memory: 5.61 GiB used: 1.73 GiB (30.8%)
Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 10.0.1 Packages: 1447
pacman: 1443 lib: 374 flatpak: 0 snap: 4 Shell: Bash v: 5.0.18
running in: konsole inxi: 3.1.05

What i tried:
First the basics i tried every things on compositor (openGL3.1,openGL2.0,xrender)
In all options , with openGL3.1 and openGL2.0 i can’t record screen (freeze screen with tearing) but with xrender i can without problems but no fix for problem above .

change firefox configurations i know its not browser problem because screen tearing on chromium but i was try to find any way

about:config”
Search for layers.acceleration.force-enabled
Change it to true
Save and restart Firefox.

this making Worse so i just back to false

Create a file /etc/X11/xorg.conf.d/20-intel.conf and paste the following code as administrator:

Section “Device”
Identifier “Intel Graphics”
Driver “intel”
Option “TearFree” “true”
EndSection

another i tried:

Section “Device”
Identifier “Intel Graphics”
Driver “intel”
Option “AccelMethod” “uxa”
EndSection

also i tried:

Section “Device”
Identifier “Intel Graphics”
Driver “intel”
Option “AccelMethod” “uxa”
Option “TearFree” “true”
EndSection

firefox performance :

unable/able “use recommended performance”
unable/able “use hardware acceleration when available”

I hope any one have any why to slove screen tearing,because ilove linux ilove manjaro ididn’t want back windows for this type of problems.
Thanks to all

In system settings, on the compositor screen try to set Sync-V to total refreshes (and keep the tearfree option in the xorg configuration).

I read this in one of topics in this form (or old maybe ) and i tried ,nothing change.
i try what i mentioned on every posable way.
Now i use wayland ,better not full fixed and its slow. it doesn’t like a solution.
sorry for my english .

note : i use wayland only when i want watch video because its slow , and tear in scrolling and some in video watch still (but less).

I’m sorry, but besides these suggestions, I dont’ have any more ideas.

thank you, i tried this.
i don’t want back to windows for that reason , but what i can do.
i steal searching, many users have same problem .
i don’t know why this bug steal exist, I’m not developer so i didn’t know if do something to this bug so hard but i wish if someone do something .
if any one have anything to tearing.