Screen tearing in Manajro Xfce

I am facing
A very bad screen tearing issue

  1. I suspend my laptop because I not able to shut down my laptop as my screen gets stuck after then I have to hard shutdown …

2.Whenever I open my laptop after suspending I get an error like this every time …

  1. after a hard shutdown I also came to face an error like this…

And last but not least
My hardware information

[ayushk@ayush-inspiron3541 ~]$ inxi -F
  Host: ayush-inspiron3541 Kernel: 5.12.1-2-MANJARO x86_64 bits: 64 
  Desktop: Xfce 4.16.0 Distro: Manjaro Linux 
  Type: Portable System: Dell product: Inspiron 3541 v: N/A 
  serial: <superuser required> 
  Mobo: Dell model: Inspiron 3541 v: A07 serial: <superuser required> 
  BIOS: Dell v: A07 date: 11/27/2015 
  ID-1: BAT0 charge: 1.5 Wh (93.8%) condition: 1.6/41.4 Wh (4.0%) 
  Info: Quad Core model: AMD A6-6310 APU with AMD Radeon R4 Graphics 
  bits: 64 type: MCP cache: L2: 2 MiB 
  Speed: 998 MHz min/max: 1000/1800 MHz Core speeds (MHz): 1: 998 2: 1519 
  3: 1796 4: 1015 
  Device-1: AMD Mullins [Radeon R4/R5 Graphics] driver: radeon v: kernel 
  Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo 
  Display: x11 server: X.Org 1.20.11 driver: loaded: radeon 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: AMD KABINI (DRM 2.50.0 5.12.1-2-MANJARO LLVM 11.1.0) 
  v: 4.5 Mesa 21.0.3 
  Device-1: AMD Kabini HDMI/DP Audio driver: snd_hda_intel 
  Device-2: AMD FCH Azalia driver: snd_hda_intel 
  Sound Server-1: ALSA v: k5.12.1-2-MANJARO running: yes 
  Sound Server-2: PulseAudio v: 14.2 running: yes 
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169 
  IF: enp2s0 state: down mac: 20:47:47:53:db:2d 
  Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 
  driver: ath9k 
  IF: wlp3s0 state: up mac: b0:c0:90:62:24:ff 
  Device-1: Qualcomm Atheros AR9462 Bluetooth type: USB driver: btusb 
  Report: rfkill ID: hci0 state: up address: see --recommends 
  Local Storage: total: 465.76 GiB used: 186.49 GiB (40.0%) 
  ID-1: /dev/sda vendor: Seagate model: ST500LT012-1DG142 size: 465.76 GiB 
  ID-1: / size: 450.29 GiB used: 186.49 GiB (41.4%) fs: ext4 dev: /dev/sda1 
  ID-1: swap-1 type: partition size: 7.2 GiB used: 0 KiB (0.0%) 
  dev: /dev/sda2 
  System Temperatures: cpu: 61.0 C mobo: 54.0 C gpu: radeon temp: 62.0 C 
  Fan Speeds (RPM): cpu: 4834 
  Processes: 204 Uptime: 22m Memory: 3.28 GiB used: 1.55 GiB (47.3%) 
  Shell: Bash inxi: 3.3.04 
[ayushk@ayush-inspiron3541 ~]$ 

here is my hardware info
I have faced this error for a long time
and tried many solutions and all other kinds of stuff I got on the internet but none of them worked

Hope that this problem will be solved soon enough

That indeed looks bad

My first attempt - should it be my system - would be a firmware update.

I have not touched AMD devices for more than 20 years - maybe closer to 25 - but it appears to be some integrated stuff - like Intel UHD630 - but for AMD?

A search using the keywords Linux Radeon R4/R5 Graphics seems to indicate that AMD proprietary software is needed - but as said - never been around AMD based systems.

  1. how can I do a firmware update for my specific hardware

  2. do I have to try installing the proprietary drivers ??

  3. whenever I press the brightness key in my laptop for changing brightness there is a bit of lag in changing the brightness I mean it takes 1-2 seconds more to complete the action (is this some kind of indication or something which represents a fault in driver )