Screen Tearing - A lot of it

Hey lovely Manjaro people,

I do experience a lot of screen tearing. I do have issues fixing my outdated graphics card and I am beginner user anyway so I am really at the limit of my little capabilities. But I feel even without getting optirun doing its work, the screen tearing shouldn’t occur at all.

I do experience the screen tearing on three different Displays, my built in laptops Display, my desktop Display (Samsung S24D390) and my old Phillips HD-flatscreen TV.

It is so strong and distracting. My eyes are hurting, its awful. I found a video on YouTube testing it and my screens are going wild (/watch?v=MfL_JkcEFbE).

I am using a Thinkpad W540 which does have a Nvidia chip built into it but it doesn’t show up in the about Page.

Btw here is my about page:
Operating System: Manjaro Linux
KDE Plasma Version: 5.20.4
KDE Frameworks Version: 5.77.0
Qt Version: 5.15.2
Kernel Version: 5.10.2-2-MANJARO
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-4800MQ CPU @ 2.70GHz
Memory: 15.5 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 4600

And there you got my inxi -Fazy command print:

$ inxi -Fazy
System:
  Kernel: 5.10.2-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=96197d22-38ae-4c28-9aa9-c6524b7e8040 rw 
  resume=UUID=99721703-11e6-4ea0-95f2-38b90e2256d2 udev.log_priority=3 
  Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: LENOVO product: 20BHS0L000 v: ThinkPad W540 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: LENOVO model: 20BHS0L000 serial: <filter> UEFI: LENOVO 
  v: GNET90WW (2.38 ) date: 03/25/2019 
Battery:
  ID-1: BAT0 charge: 86.8 Wh condition: 89.2/99.5 Wh (90%) volts: 12.2/10.8 
  model: SANYO 45N1779 type: Li-ion serial: <filter> status: Unknown 
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M510 
  serial: <filter> charge: 50% (should be ignored) rechargeable: yes 
  status: N/A 
CPU:
  Info: Quad Core model: Intel Core i7-4800MQ bits: 64 type: MT MCP 
  arch: Haswell family: 6 model-id: 3C (60) stepping: 3 microcode: 28 
  L2 cache: 6 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 43117 
  Speed: 798 MHz min/max: 800/3700 MHz Core speeds (MHz): 1: 798 2: 798 3: 798 
  4: 799 5: 798 6: 801 7: 798 8: 798 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: Lenovo 
  driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0416 
  Device-2: NVIDIA GK107GLM [Quadro K1100M] driver: N/A 
  alternate: nouveau, nvidia_drm, nvidia bus ID: 01:00.0 chip ID: 10de:0ff6 
  Device-3: Lite-On Integrated Camera type: USB driver: uvcvideo 
  bus ID: 3-12:7 chip ID: 04ca:7035 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: intel 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1013x285mm (39.9x11.2") 
  s-diag: 1052mm (41.4") 
  Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") 
  diag: 389mm (15.3") 
  Monitor-2: HDMI1 res: 1920x1080 hz: 60 dpi: 94 size: 520x290mm (20.5x11.4") 
  diag: 595mm (23.4") 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2) 
  v: 4.5 Mesa 20.3.1 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio 
  vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:03.0 
  chip ID: 8086:0c0c 
  Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:8c20 
  Device-3: NVIDIA GK107 HDMI Audio driver: snd_hda_intel v: kernel 
  bus ID: 01:00.1 chip ID: 10de:0e1b 
  Sound Server: ALSA v: k5.10.2-2-MANJARO 
Network:
  Device-1: Intel Ethernet I217-LM vendor: Lenovo driver: e1000e v: kernel 
  port: 5080 bus ID: 00:19.0 chip ID: 8086:153a 
  IF: enp0s25 state: down mac: <filter> 
  Device-2: Intel Wireless 7260 driver: iwlwifi v: kernel port: efa0 
  bus ID: 03:00.0 chip ID: 8086:08b2 
  IF: wlp3s0 state: up mac: <filter> 
  IF-ID-1: nordlynx state: unknown speed: 10 Mbps duplex: full mac: N/A 
Drives:
  Local Storage: total: 931.52 GiB used: 262.32 GiB (28.2%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Intenso model: SSD Sata III 
  size: 465.76 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 6A 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT500MX500SSD1 
  size: 465.76 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 023 
Partition:
  ID-1: / raw size: 448.39 GiB size: 440.35 GiB (98.21%) 
  used: 262.23 GiB (59.6%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 280 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 
Swap:
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 17.07 GiB used: 90.1 MiB (0.5%) 
  priority: -2 dev: /dev/sda3 maj-min: 8:3 
Sensors:
  System Temperatures: cpu: 50.0 C mobo: 0.0 C 
  Fan Speeds (RPM): cpu: 1671 
Info:
  Processes: 259 Uptime: 1d 5h 01m wakeups: 7 Memory: 15.52 GiB 
  used: 6.82 GiB (44.0%) Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: 
  pacman: 1555 lib: 480 Shell: Bash v: 5.1.0 running in: konsole inxi: 3.2.01 

It is not possible to use this machine in a meaningful way, because these glitches are THAT bad.

So if you are willing to help out a beginner, maybe walk me threw a few things - it would be highly appreciated :slight_smile:

1 Like

There’s a few posts about prime synchronisation and it sounds like your issue. The solution is to use kernel 5.4lts until the nvidia drivers hit 460

3 Likes

can you please help me doing so without harming my system (which I am afraid of doing without being helped)? I would be very thankful. I tried just going in the GUI in the system settings under kernels and i do see many different kinds… but I don’t see how to change it?

I just followed Manjaro Kernels - Manjaro this but no succes

In the Manjaro Settings Manager, scroll down to the 5.4 LTS kernel (probably also says "recommended next to it) and select install. This should install the 5.4 LTS kernel for you. Did you do this?

When you reboot, you will need to select the 5.4 LTS kernel from your GRUB menu (Selecting Kernels). This should boot you using 5.4. Did you select this option in GRUB?

also I do experience even more graphics related bugs

Yes they are installed.

alright… so next step: finding out how to enter the grub menu

thanks mate

Sorry I’ve just re-read your info and you are using the nouveau open soruce driver. I’m not sure what nvidia drivers are compatible with your card but it could be a kde issue

Ok, if the GRUB menu is not shown by default on your system then the next thing to do would be to enable the menu. if you enter the following in a terminal:
sudo nano /etc/default/grub
you should be able to edit your GRUB config. You need the GRUB_TIMEOUT_STYLE line to be changed to:
GRUB_TIMEOUT_STYLE=menu
then save the file and exit your nano editor, then enter:
sudo update-grub

If your intel graphics chip is the one being used by your system - I thought that’s what your post indicated - then if the kernel change to 5.4 doesn’t help then there is a change in the X11 config file that may help. This is taken from the Arch wiki here: Intel Screen Tearing
enter sudo nano /etc/X11/xorg.conf.d/20-intel.conf then:

Section "Device"
  Identifier "Intel Graphics"
  Driver "intel"

  Option "TearFree" "true"
EndSection
1 Like

I wanted to downgrade my kernel anyway, just to try if its helping so the help is appreciated.

But yeah eventually I would like to get my nvidia chip working as well.

Ok great. Let us know how you get on with the update to GRUB and boot into 5.4. From what I can tell, your screen tearing is most likely a configuration issue with your intel chip, as I think that is what is being used by your X display server. Hopefully something here does the trick.

you can also press “shift” or “esc” during boot to enter grub

2 Likes

Doesn’t always work, certainly doesn’t on my laptop, but is an option. Editing so that the menu always shows will always work though.

1 Like

It was easily possible to boot into the 5.45.85-1 Kernel and I immediately tried the screen tearing test video which produced subjectively a little less screen tearing but it still there.

My suddenly appearing problem with my screen resolution is still there as well (Screen resolution an Thinkpad Laptop)

So I will take a look at the wiki article about the intel screen tearing and the commands you’ve been advising me now.

Its an empty text file… I think nano created a new one. I am supposed to find a text file similar to the grub thing or is it the idea to create a new one?

Yes, if you do not have one already then you can just paste that text in there as mentioned on the Arch wiki and save the file.

I also just remembered that there is an option for vsync in Manjaro KDE Compositor System Settings; if you go to System Settings>Hardware>Display and Monitor>Compositor, you can change the Rendering Background between different versions of OpenGL and you can also change “tearing prevention (VSync)” to automatic, full screen repaints etc. Might be worth having a look to see if any of these help as well, if the X11 config file doesn’t help.

It didn’t help anything.

My Displays are playing wild now showing the wrong resolutions everything is crumbling… i am very close to have a breakdown because i don’t know what I’m doing and nothing is helping whatsoever.

when booting, my laptop display is showing just a magnified part of the overall image and i don’t know whats happening everything is failing since i went to 5.10. or at least around that time. I think I must try to reinstall the graphic drivers or something but man my motivation is very low because of all the hours spent and no results :frowning:

do you think i could be more lucky with debian?

I’m not sure then, sounds like a lot of different issues you are having that stem from issues with your graphics driver. I completely sympathise with your lack of motivation. I can only really suggest trying the other Intel driver options available (e.g. modesetting) to see if any improvement, and/or trying to get your NVidia chip working (I have read of a lot of issues with NVidia and Linux, so this might be a test of patience too).

I have only used Debian in CLI only mode on servers, so cannot really say how this will help with regards to your issues, but it certainly is an option available. I think older NVidia drivers might still be supported there though (can compile on other distributions like Manjaro, but may not necessarily be working out of box), so that might be useful to you.

Whatever you choose, best of luck getting it sorted.

1 Like

On my laptop the xf86-video-intel package caused a lot of trouble like screen tearing etc.
The solution is very easy and was found here
Maybe it works also for you?

Thanks but did you intentionally link to an answer provided in this very thread? because i tried this already of course. Or did you mean to link to something else??