Screen remnants when using multiple screens


Since approximately 3 month, after an update via pacman -Syu I have experienced weird screen behaviour. sorry to not write earlier but I had to do work and figured it gets fixed probably anyway.

Before this update everything was working very well.
When having activated only one screen everything is fine, when using multiple (I sometimes use 2, sometimes 3 screens) only the primary screen gets updated correctly.

The other ones seem to not ‘delete their drawings’, meaning I get these weird graphical glitches some might still remember from windows NT…

Here is an image as this might be more clear:
apparently I cant embed images even though the editor offered me the option and took the upload… so here we have to go…
okaaay… so I can’t also embed LINKS in this post… so here you have to copy paste yourselves…

So if I close apps/windows on such a display, they still are visually there.

using arandr to generate and export scripts, f.e.

xrandr --output eDP-1 --mode 1920x1080 --pos 0x1080 --rotate normal --output DP-1 --off --output HDMI-1 --off --output DP-2 --off --output HDMI-2 --primary --mode 1920x1080 --pos 0x0 --rotate normal

Please add system information from inxi -Fazy.

Do you have a Nvidia GPU? Which compositor are you running? Do you have any content in any file in /etc/X11/xorg.conf.d/*.conf?

graphicsCard: Intel HD Graphics 620

inxi -Fazy with some unnecessary details omitted:

  Kernel: 5.13.19-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.13-x86_64
    root=UUID=<SOMEUUID> rw rootflags=subvol=@ quiet
    root=/dev/mapper/luks-<SOMEUUID> apparmor=1
    security=apparmor udev.log_priority=3 i915.enable_psr=0
  Desktop: i3 v: 4.22 info: i3bar vt: 7 dm: LightDM v: 1.32.0
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 20HMS12K00 v: ThinkPad X270
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 20HMS12K00 v: SDK0J40697 WIN
    serial: <superuser required> UEFI: LENOVO v: R0IET61W (1.39 )
    date: 04/20/2020
  Info: model: Intel Core i5-7300U bits: 64 type: MT MCP arch: Amber/Kaby Lake
    note: check gen: core 7 level: v3 note: check built: 2017 process: Intel 14nm
    family: 6 model-id: 0x8E (142) stepping: 9 microcode: 0xF0
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1684 high: 2504 min/max: 400/3500 scaling:
    driver: intel_pstate governor: powersave cores: 1: 1388 2: 900 3: 2504
    4: 1947 bogomips: 21607
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel HD Graphics 620 vendor: Lenovo driver: i915 v: kernel
    arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: HDMI-A-2
    off: eDP-1 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:5916
    class-ID: 0300
  Device-2: Acer Integrated Camera type: USB driver: uvcvideo bus-ID: 1-8:5
    chip-ID: 5986:111c class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.6 compositor: Picom v: git-b700a driver:
    X: loaded: modesetting alternate: fbdev,vesa dri: iris gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 506x285mm (19.92x11.22")
    s-diag: 581mm (22.86")
  Monitor-1: HDMI-A-2 mapped: HDMI-2 pos: primary model: Idek Iiyama PL2480H
    serial: <filter> built: 2013 res: 1920x1080 hz: 60 dpi: 94 gamma: 1.2
    size: 521x293mm (20.51x11.54") diag: 598mm (23.5") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  Monitor-2: eDP-1 note: disabled model: ChiMei InnoLux 0x1239 built: 2015
    res: 1920x1080 dpi: 177 gamma: 1.2 size: 276x155mm (10.87x6.1")
    diag: 317mm (12.5") ratio: 16:9 modes: 1920x1080
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo missing.
  Processes: 270 Uptime: 1h 39m wakeups: 2 Memory: 15.38 GiB
  used: 3.62 GiB (23.6%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: 1796
  pm: nix-default pkgs: 0 pm: nix-sys pkgs: 0 pm: nix-usr pkgs: 54 libs: 11
  pm: pacman pkgs: 1734 libs: 401 tools: pamac,yay pm: snap pkgs: 8 Shell: Zsh
  v: 5.9 running-in: urxvtd inxi: 3.3.24

I have content in /etc/X11/xorg.conf.d/*.conf:

 $: cat /etc/X11/xorg.conf.d/*.conf
# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "de"
Section "InputClass"
    Identifier "touchpad"
    Driver "libinput"
    MatchIsTouchpad "on"
    Option "Tapping" "on"
Section "InputClass"
		Identifier "11"
		Driver "libinput"
		MatchIsTouchpad "on"
		Option "AccelSpeed" "0.4"

Dont know if this was just magic coincidence, however it appears to be fixed with this upgrade

Packages (4) lib32-mesa-22.3.4-2  lib32-mesa-vdpau-22.3.4-2
             lib32-vulkan-intel-22.3.4-2  lib32-vulkan-radeon-22.3.4-2

testing for a few more hours/days though

Appears to not be solved, sadly.

Seems to me to be somewhat random. Sometimes my second external monitor works fine but my laptop display does not. Sometimes the second one also has these remnants.

Could you try without the compositor? (remove the picom call from you i3 config).

1 Like

just now it seems to work without picom. 20 days ago It seemed to be solved aswell so I am not trusting this yet.

any hints on how to verify picom is causing this? or how to configure?

I don’t know. I have probably the same issue and disabling picom seems to resolve it. Additionally, I don’t know why picom is “needed” anyway. (Translucent windows don’t make much sense in i3.)

1 Like

bit offtopic as its about translucency in i3wm:
for me this is just asthetics. did use it sometimes, as windows can still be put in foreground and scrachpadded (f.e. bindsym $mod+minus scratchpad show and bindsym $mod+Shift+space floating toggle from my i3conf )

so for now this is a quick makeshift solution and I’m not having the time currently to look into why this happens with picom and how to fix it, still it’d be worth the fix for quite some people I imagine using the transparency features.