Screen Recording problem

I have installed Manjaro recently and I need a screen recorder software but none of them work, just simple screen recorder runs under gnome on Xorg, others don’t run at all

What do you mean by “none” and “not working”? I have gnome installed on my laptop and every screen recorder works. Example:

  1. simplescreenrecorder
  2. vokoscreen
  3. peek
  4. obs-studio

What exactly is the problem?

vokoscreen
peek
obs

do not run, I have installed them, and when I click on the icons nothing happens,

about simple screen I mentioned that it only runs if you log gnome on Xorg

The gnome built-in recording tools should work under Wayland…

For obs:

It’s also important to note that OBS Studio can’t record the desktop on Wayland by default** (and the application itself doesn’t run under Wayland so you have to run it under XWayland). However, it’s possible to record (and broadcast) your desktop under Wayland with OB Studio by using a plugin like the obs-xdg-portal plugin (works with both Wayland and X11 on GNOME and KDE, perhaps others as well), or the GNOME Screen Cast OBS Studio plugin (works with all GNOME sessions, including Wayland).

To run it under xwayland does to have xorg-server-xwayland installed is enough? Or other tricks is needed… i don’t know i never tried Wayland yet

Otherwise on X11 i never had issue with obs

what Dekstop Environment you are using in manjaro?

Plasma… but i never saw issue about obs beside hardware accelerated encoding on the forum.

And on Wayland the screen recording option are still limited now.

You can try the flatpak version of obs it seems the plugins for recording on Wayland is included.

Both plugin seems to be available on AUR but i never tried them and it may need to read their doc for how to use them

I found the problem, it is Wayland and now I don’t know how to disable it!

I don’t know gnome or gdm, but at the login screen you should have option to choose which session to open… gnome wayland or gnome xorgs (I don’t know the exact names) and it should remember the last one you openend…

yes exactly, thank you