Screen recording having screen artifacts

So I had asked this question once but somehow I can’t find it in my activity or posts and stuff so I don’t know where to go in order to fix the problem I had. I recently had to reinstall Manjaro again and I have the flickering, artifact thing when trying to screen record using simple screen recorder and obs. I will provide my brief system info as well as a screenshot of what im more or less seeing.

[ok so this is where the image would be but apparently I can’t use media in posts so you guys will prob know what im talking about hopefully]

Machine:   Type: Laptop System: Hewlett-Packard product: HP Pavilion 15 Notebook PC v: 0896100000304100000620100 
           serial: <filter> 
           Mobo: Hewlett-Packard model: 2163 v: 29.42 serial: <filter> UEFI: Insyde v: F.72 date: 03/09/2018 
Battery:   ID-1: BAT0 charge: 21.8 Wh condition: 21.8/21.8 Wh (100%) model: Hewlett-Packard Primary status: Full 
CPU:       Topology: Dual Core model: Intel Core i3-4005U bits: 64 type: MT MCP arch: Haswell rev: 1 L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 13574 
           Speed: 798 MHz min/max: 800/1600 MHz Core speeds (MHz): 1: 798 2: 799 3: 798 4: 799 
Graphics:  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: Suyin HP Truevision HD type: USB driver: uvcvideo bus ID: 2-3:3 
           Display: x11 server: X.Org 1.20.9 driver: intel unloaded: modesetting resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) v: 4.5 Mesa 20.1.8 direct render: Yes 
Audio:     Device-1: Intel Haswell-ULT HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:03.0 
           Device-2: Intel 8 Series HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           Sound Server: ALSA v: k5.8.16-2-MANJARO 
Network:   Device-1: Realtek RTL8188EE Wireless Network Adapter vendor: Hewlett-Packard driver: rtl8188ee v: kernel port: 4000 
           bus ID: 08:00.0 
           IF: wlo1 state: down mac: <filter> 
           Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 
           bus ID: 09:00.0 
           IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 698.64 GiB used: 37.58 GiB (5.4%) 
           ID-1: /dev/sda vendor: Western Digital model: WD7500BPVX-60JC3T0 size: 698.64 GiB 
Partition: ID-1: / size: 183.79 GiB used: 37.55 GiB (20.4%) fs: ext4 dev: /dev/sda6 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 46.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 193 Uptime: 4h 26m Memory: 15.57 GiB used: 2.13 GiB (13.7%) Init: systemd Compilers: gcc: 10.2.0 
           Packages: 1251 Shell: Bash v: 5.0.18 inxi: 3.1.05```

Howdy!

Can you go into System Setting >> Hardware >> Display and Monitor >> Compositor and change the tearing prevention to “Full screen repaints”, see if it fixes the issue, please?

May also want to change the Compositor Rendering Back-end to either OpenGL 3, or Xrander!

Hope this helps, have a wonderful day!

hey @The_Quantum_Alpha I tried what you suggested and the Xrender option did fix the tearing but I was loosing blur so I tried just messing around with the options from the rendering back end and the tearing prevention.

And setting the “Tearing prevention” to “Never” also seems to fix my issue and don’t have to loose blurring. Also decided to stay with “OpenGL 3.1” cause well idk if it’s better then OpenGL 2.0 I figure it is.

But yes my problem is fixed so far. :slight_smile: Thanks for the help Hope you have a wonder day or night.

1 Like

Sweet! Glad I could help!:smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.