Screen recorder issues

Every time I record in Manjaro with Kazam, it shows nothing, only the movement of the mouse is known.I even tried with simplescreenrecorder, but the result was the same
my laptop is Acer TravelMate 5742z and my Manjaro version is x86_64 20.2 Nibia.
where is the problem from??

@ammar_salahi are you using wayland with gnome? If yes, only a few screenrecorder can record that. Most work with xorg.

Please post the output of:

inxi -Fazy

simple screencast recording (no audio) is built-in in gnome. You can use the shortcut

[CTRL] + [ALT] + [SHIFT] + [R]

Works in Wayland too

Hi and welcome to the forum :+1:

FYI: I renamed the tile and added categories to better reflect the issue :handshake:

Yes, I only work with GNOME. I can’t enter xorg and wayland because the login is repeated.

don’t know if this will help but same problem in kde was solved with compositor settings…
rendering backend set to XRender and Tearing prevention (“vsync”) set to Full screen repaints…

I assume that you mean that when you are at the login screen, and click the little gear icon at the bottom right of the screen, and you get a choice of DEs to log in to, you choose ‘GNOME’ rather than ‘GNOME on Xorg’ (or ‘GNOME classic’). I think that this means you are running Gnome through Wayland, and as other posters have suggested, this will be why the screen recorder is not working. It sounds like you may be having problems running Xorg - I guess you have two options - get Xorg up and running and run your gnome session on that, or research further into screen recorders for Wayland - if you search ‘wayland screen recorder’ on Google or DuckDuckGo (or your search engine of choice!) you should find some further ideas about what might work