Screen randomly freezes after being blanked on Gnome

I have a HP Proliant DL380G7 server and I use it as my daily computer with GTX1650.
I’ve used an older generation server (HP Proliant DL380G6) with the exact same graphics card for about 6 months with Manjaro Gnome and the same monitors and I had no issues with this setup.

Because I use a server, I can’t put it to sleep (also, I have VMs with servers running there). I always used to set the “Blank Screen Delay” to something like 2/3 minutes with screen locking disabled.

About a week ago I switched to the newer server and installed Manjaro there and I’ve noticed a really irritating bug. Sometimes (about 1 time a day) my main screen randomly turns on (the backlight turns on) but there’s nothing on the screen aside from a cursor, and the 2nd monitor is in sleep state. When I move my mouse the 2nd monitor turns on but there’s nothing there as well, only the backlight turns on but there’s nothing on the screen (sometimes the cursor is on the 2nd monitor, depending on where I left it).
The cursor doesn’t move (even though the system reacts to moving the mouse by turning on the 2nd monitor). Pressing CTRL+ALT+F3 to bring up TTY doesn’t work as well. The system, aside from graphical part, work fine because virtualized servers keep running and are functional.
An interesting thing for me is that when it DOESN’T freeze and I move the mouse for a split second I can see a Gnome lock screen on my primary monitor. Does Gnome “lock” the screen while blanking it? Can it be a part of the issue?

I’ve also tried changing the refresh rates of both monitors, to no avail.

The kernels I’ve tested: Linux 5.11.2-1; Linux 5.10.19-1; Linux 5.9.16-1
NVIDIA driver: 460.56
DE: Gnome (I really want to stick to it)
Primary monitor: Lenovo L2264A connected via HDMI
Secondary monitor: Eizo FlexScan EV2316W connected via DP/DVI (tested with both)

The system has been reinstalled a couple of times.

The other weird thing I’ve noticed on the new system is that NVIDIA X SERVER settings are not loaded after reboot (yes they are saved properly in the /etc/X11/xorg.conf). After applying the settings in NVIDIA X SERVER they work… until the next reboot. That wasn’t the problem on the old system.

Save to /etc/X11/mhwd.d/nvidia.conf and remove /etc/X11/xorg.conf.

1 Like

Thank you for your advice!
Now NVIDIA X SERVER settings work and are applied after reboot, but the problem still exists. It still does freeze from time to time and requires a reboot, even though I tried changing some settings in NVIDIA X SERVER Settings.
I guess the problem is the new graphics driver…
Well, thanks for help! :heart: